9

I upgraded to to Graphics Installer 1.0.6 on my Ubuntu 14.04 and installed the drivers using the Intel Graphics Installer. The laptop is Intel Ivybridge powered with Intel HD graphics. It Optimus but I have disabled the Nvidia card in bios. The Intel Graphics Installer installs the package i915-3.15-3.13-dkms.deb which I assume is the updated driver. It causes a bunch of error messages when I boot. Here are the relevant errors from dmesg when I boot:

[    7.206151] drm: module verification failed: signature and/or  required key missing - tainting kernel
[    7.208045] drm: module has bad taint, not creating trace events
[    7.336470] fb: conflicting fb hw usage inteldrmfb vs VESA VGA - removing generic driver
[    7.393854] [drm] Supports vblank timestamp caching Rev 2 (21.10.2013)
[    7.393855] [drm] Driver supports precise vblank timestamp query.
[    7.393921] vgaarb: device changed decodes: PCI:0000:00:02.0,olddecodes=io+mem,decodes=io+mem:owns=io+mem
[    7.505798] [drm] GMBUS [i915 gmbus dpb] timed out, falling back to bit banging on pin 5
[    7.507233] init: Failed to obtain startpar-bridge instance: Unknown parameter: INSTANCE
[    7.944183] [drm:cpt_serr_int_handler] *ERROR* PCH transcoder A FIFO underrun
[    8.368479] i915 0000:00:02.0: fb0: inteldrmfb frame buffer device
[    8.368480] i915 0000:00:02.0: registered panic notifier
[    8.818416] [drm] Enabling RC6 states: RC6 on, RC6p on, RC6pp off

What could the problem be and will it affect performance? I tried to remove the package and the errors went away but I'm then running and older driver I assume?

6

Here is how I uninstalled the latest Intel Graphics Driver :

Open a new Terminal (CTRL+Alt+T) and execute

gksudo gedit /etc/apt/preferences.d/intel-removal

Paste this code in the File and save it

Package: *
Pin: release a=trusty*
Pin-Priority: 1001
Package: *
Pin: origin download.01.org
Pin-Priority: -100

Run

sudo apt-get dist-upgrade

You will be asked to downgrade about 20 packages and that's what you want.

Just some cleaning up to do:

sudo rm /etc/apt/preferences.d/intel-removal

sudo rm /etc/apt/sources.list.d/intellinuxgraphics.list*

sudo apt-get update

Now you must delete the actual drivers :

sudo apt-get purge i915-3.15-3.13-dkms intel-linux-graphics-installer

Finally reboot

  • Any information when the latest Intel Graphics Driver will be fixed, so you can upgrade instead of downgrading? I'm experiencing the same problem. – Sami Lehtinen Sep 29 '14 at 16:07
2

I was using intel-graphics-driver until 1.0.5 with no problem. I have updated to 1.0.6 and I started to have problems. No image at all. I see now that this drivers are not compatible with low latency kernel (funny it worked before) Uninstalled drivers and now I don't know how to fix it. Running on failsafe mode now.

I have found a solution. Even if it is not working as before, it's working and that's enough for me.

As suggested in this thread, I solved it turning off bootloader graphics:

Try turning off the bootloader graphics. Run this command in a Terminal window:

gksudo xdiagnose

Click the checkbox labeled "Disable bootloader graphics", hit Apply, then reboot.

2

I had this problem and when I finally managed to get to desktop I run Synaptic Package Manager (the old abandoned friend:-)), selected "Origin" from filters, clicked the intel repo (download. 01.org) and then forced every package from the list to downgrade to trusty version. Rebooted, disabled the repo altogether and voila - all reverted back to not-crappy version from before the mess :-)

I'm wondering if this process is achievable without Synaptic - from terminal (?)

0

It's wierd but I have tried everything but eventually installing lightdm rescued the system. All your suggestions here did not work somehow.

# apt-get install lightdm

and then selecting lightdm as the default manager when it asks brought the system back.

# sudo reboot
0

AFAIU it's reported on kernel.org here: https://bugzilla.kernel.org/show_bug.cgi?id=79261

protected by Community Aug 12 '17 at 9:33

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.