1

I am using Ubuntu 14.04. I can press Alt+| to switch windows of the same application. How can I change this keyboard shortcut to something else? I have tried using Gnome Control Center under System Settings->Keyboard->Shortcuts->Navigation and the CompizConfig Settings Manager (ccsm).

2

The CompizConfig Settings Manager is the correct application to use to change this keyboard shortcut when you're using Compiz as your window manager.

Compiz has several plugins that can be used to switch between applications, and they all have a different look & feel:

  1. Application Switcher
  2. Ring Switcher
  3. Shift Switcher
  4. Static Application Switcher

In ccsm, you can enable or disable a plugin by using the little checkbox on the left of the plugin icon. Try the four switcher plugins above (always only enable one at a time to avoid conflicts) and decide which one you like best.

The Application Switcher plugin does not support (as far as I can see) switching windows of the same application. The other three plugins do, though: To change the keyboard shortcut for switching windows of the same application, click on the plugin icon that you are using and look for a setting like Next/Previous Window Key (Group). Example for the Shift Switcher:

enter image description here

| improve this answer | |
  • Thanks! I will test this now.. I have currently not enabled any of the switchers you mention above. So I wonder: why is this choice (Next Window Key (Group)) not listed under the Ubuntu Unity Plugin Switcher (in ccsm->Desktop->Ubuntu Unity Plugin->Switcher) – Håkon Hægland Aug 5 '14 at 11:47
  • I tried the Shift Switcher with Ctrl+|.. And it did not work. First issue: the old keyboard shortcut is still working (Alt+|), second issue: The switcher is not working: I opened two windows of my web browser (chromium) and tried pressing Ctrl+|. One time the switcher opened but I could not change windows, and the other time Ubuntu crashed with an internal error.. – Håkon Hægland Aug 5 '14 at 11:57
  • Ok. First, try to use some keyboard shortcut that's not already in use. If there are conflicts, of course it is not surprising that this won't work as expected. Once you've made sure it works with some otherwise unused keyboard shortcut, you can try to set whatever shortcut you like and disable that shortcut elsewhere in order to get rid of conflicts. Second, don't start out with the Shift Switcher or the Ring Switcher. These have some fancy effects that may lead to those crashes on your system. Try the very simple Static Application Switcher first. :-) – Malte Skoruppa Aug 5 '14 at 12:14
  • Also, I'm not familiar with the Unity plugin for Compiz, so I can't tell you much about it. (I do use Compiz, but not Unity.) I guess that the Unity plugin implements (among other things) its own application switcher, whose shortcuts you can configure there, and which is completely unrelated to the other "standard" Compiz switcher plugins. This would explain why none of the other switchers were enabled for you. But you can certainly enable them anyway, and unset the application switcher shortcuts in the Unity plugin, so as to use a different (non-Unity) implementation of an app switcher. – Malte Skoruppa Aug 5 '14 at 12:26
  • Ok thanks for helping me out :). I still have problems. I disabled Shift Switcher then tested if Ctrl+| had any effect in my applications, to make sure that the shortcut was not already defined. Then I enabled Static Application Switcher with Ctrl+| for switching windows in same group. This worked for gnome-terminal windows, but not for Chromium, Emacs, and Okular windows.. – Håkon Hægland Aug 5 '14 at 12:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.