I unfortunately have notebook ASUS K50C which uses a sis graphics driver. I tried many different options from different forums but I am still having screen resolution problems. Its screen resolution is still really low. Despite that, I cannot watch any kind of video as computer becomes overloaded is not able to play the video normally. I am currently using UBUNTU 14.04. Can anyone help me to solve the problems or does anybody know which version of Ubuntu works fine with this computer? Thanks in advance


4 Answers 4


I've just finished loading Ubuntu onto a Dell fx160 thin client that has the SiS 771/617 video adapter as standard. I originally loaded 16.04 and it acted like a dog, you could see the interlacing and the whole system was slooow.

Looking through Xorg.0.log I noticed that the Sis driver native in Xorg wasn't rated for the 771/617, and the only driver I could find for the 771/671 was noted here: https://sites.google.com/site/easylinuxtipsproject/sis One developed by Antonio J. de Oliveira, most of whose work is now missing from the internet. Pity, coz he's the only guy who seemed to do much with the SiS cards. And maybe due to the age of his driver, it was compiled against the kernel used in Ubuntu 12.04.1. (note the ver 1. I loaded 12.04.4 which I had handy, and it didn't work. I had to go back in Ubuntu archives and get v1).

Bunged sis671_drv.so into /usr/lib/xorg/modules/drivers edited xorg.conf so that Section Device had sis671 as driver and fired it up. No problems! and plenty of resolutions to choose from in display settings.

For some reason settings can't detect the monitor and insists on calling it a laptop, and I cannot get dual monitors to work. They did work as desktop in one test iteration, so it can be done, but the two monitors were different resolutions and I couldn't find the way to alter them independently. The larger monitor, on dvi, wasn't lined up properly and it's resolution was awry. I tried a virtual monitor definition in xorg.conf, but that just made it lock up and I'd have to go back to root cli to rename xorg.conf so that it would start on defaults not conf. The fx160 has a vga and a dvi on the one SiS card. In the end, I had to put the main monitor on the vga output. I don't know if sis671_drv has the functionality for dvi or dual monitors. I know it makes the xorg log ten times normal length, so there's a lot going on in there. After all the driver is over 500kb.

If anyone gets dual head on a Ubuntu FX160 I'd be interested to hear.

  • Although , I am a fan of extensive and detailed answers myself, i would suggest condensing the post or edit it so that it has a step by step solution. Jun 12, 2016 at 23:28
  • Quod scripsi, scripsi. I like folksy answers and mentioning failed attempts is always valid. Terseness isn't always next to Godliness. Jun 13, 2016 at 2:02
  • @ross.bendigo What was the max resolution you were able to get on the FX160. I have a FX160 and trying to get to 1600x900. I'm able to get this resolution with drivers in Windows 7 but I really want to run Ubuntu MATE on this FX160
    – tkrn
    Aug 23, 2017 at 19:31

There is no currently supported version of Ubuntu which supports SiS 671/771 cards (this is bug #301958). Your options are:

  • Use an obsolete unsupported version of Ubuntu and never update. Not really recommended since you will not get security updates, but if you want to try it then 12.04.2 has been reported to work.

  • Try Linux Mint 13. There have been reports that it contains some older modified SiS driver that works.

  • Give up and buy a laptop with supported graphics. An old Thinkpad with ATI graphics can be bought for $50 on Ebay and it will run Xubuntu/Lubuntu well.

  • If you are a developer, you can fix the source. The issue has been brought up on the Xorg mailing list, and an Xorg developer responded (1 2)

    If those still don't work, get your hands dirty... if any particular strings appear in error messages, find those strings in the source and figure out what function is failing. Then compare the execution of the broken copy to the last working copy you remembered. If the API of some dependency changed, use git bisect to repeatedly compile the kernel or the Xserver until you find the exact line of code in the dependency that made the difference. Hacking the driver might sound hard, but it's not so hard that you have to pay someone to do it.

    The problem here is not that some gigantic reverse engineering effort is needed. The problem is that a few tiny janatorial fixes were required. And it's easy to miss one when the developer implementing the fixes doesn't have a SiS card on which to test.

Basically nobody knows what the actual problem is, so someone with the affected hardware needs to git-bisect the Xorg driver source and figure out how it got broken.


  • That is wrong. It is well known what is the problem. The graphics adapter will work with ilder versions of Xorg, but will not with new ones due to a hardware limitation.
    – Pilot6
    Jun 12, 2016 at 12:40
  • @Pilot6 Do you have a source for that claim? The Xorg developers already stated "The problem here is not that some gigantic reverse engineering effort is needed. The problem is that a few tiny janatorial fixes were required". Since older Xorg versions work fine then the problem is not a hardware limitation of the GPU, otherwise it would never have worked in the first place.
    – bain
    Jun 18, 2016 at 10:50

I recently refurbished a Fujitsu-Siemens Esprimo Mobile v5535 laptop (specs here: https://www.notebookcheck.net/Fujitsu-Siemens-Esprimo-Mobile-V5535.9149.0.html) which sports a SiS Mirage 3+ 672MX graphics chip.

The goal was to install a newish 18.04 or 18.10 32-bit variant of Ubuntu (Lubuntu to be exact). It should work on other Ubuntu variants, including 64-bit, as well as Fedora etc.

The actual working driver is located here: https://github.com/rasdark/xf86-video-sis671

And I have created a bash script to help others on quickly installing the driver here (instructions included in the comments of the script): https://gist.github.com/fevangelou/46a2885233c45011ad5c8752f18eac73


This is what I found. I work with Kubuntu 14.04 on a ASUS K50C and I have the same problem.

The driver on http://zatherz.cba.pl/sis/ can be downloaded and installed. I did not use the install routine on the website but I just clicked on it in the directory and the install process started itself. (The easy way. :-) )

I do have the right resolution right now. I hope I will not have new problems, the time will show it.

Good luck.

  • i'm going to try it now - Apr 30, 2015 at 0:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.