2

My decision was to get away from windows rigth to the newsest Ubuntu 14.04.1 - so I am new to Linux, but:

Trying to connect my locally, via ethernet cable attached printer (an old model Kyocera FS 1200 with ethernet network card in the printer) I was not successful.

.) What I know is the IP address of my printer. .) CUPS-management is principally working. .) My internet connection is through WiFi so my PCs ethernet port (RJ45) is available, the cable is attached to the printers ethernet card; in my prior windows installation the constellation was working.

Please can you give my some hints / steps how to acheive this? Do I need to use a special device URI?

Best regards and thank you in advance, joerg

  • Welcome to AskUbuntu. We're all volunteers here. I'd like to invite you to read your own question and ask yourself whether you would know how to help. Obviously, it's not possible to tell whether you configured and tested your ethernet port. This would be the fist thing to look at. – Run CMD Aug 5 '14 at 10:57
  • Seems to be ok - checked with ethtool eth0 => Link detected: yes – jogla Aug 5 '14 at 11:05
  • So then, which CUPS settings did you try. – Run CMD Aug 5 '14 at 11:06
  • first I tried with gui: just typing the ip-address is not enough. => used a special URI ie "ipp://169.254.129.130" and also socket://.... – jogla Aug 5 '14 at 11:16
  • Do I have to setup a CUPS-SERVER? – jogla Aug 5 '14 at 11:20
1

With Help from a guy on german ubuntu-board we solved it:

ifconfig -a
eth0      Link encap:Ethernet  Hardware Adresse 00:18:fe:68:44:a2  
          inet6-Adresse: fe80::218:feff:fe68:44a2/64 Gültigkeitsbereich:Verbindung
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metrik:1
          RX-Pakete:0 Fehler:0 Verloren:0 Überläufe:0 Fenster:0
          TX-Pakete:161 Fehler:0 Verloren:0 Überläufe:0 Träger:0
          Kollisionen:0 Sendewarteschlangenlänge:1000 
          RX-Bytes:0 (0.0 B)  TX-Bytes:29738 (29.7 KB)
          Interrupt:19 Speicher:f0600000-f0620000 


route -n

Kernel-IP-Routentabelle
Ziel            Router          Genmask         Flags Metric Ref    Use Iface
0.0.0.0         192.168.1.138   0.0.0.0         UG    0      0        0 wlan0
192.168.1.0     0.0.0.0         255.255.255.0   U     9      0        0 wlan0

After configuring via network manager manuelly: IP-Adresse ie. 169.254.129.1, (Printer= 169.254.129.130). Subnetmask = 255.255.255.0.

=>

ifconfig -a
eth0      Link encap:Ethernet  Hardware Adresse 00:18:fe:68:44:a2  
          inet Adresse:169.254.129.1  Bcast:169.254.129.255  Maske:255.255.255.0
          inet6-Adresse: fe80::218:feff:fe68:44a2/64 Gültigkeitsbereich:Verbindung
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metrik:1
          RX-Pakete:0 Fehler:0 Verloren:0 Überläufe:0 Fenster:0
          TX-Pakete:1079 Fehler:0 Verloren:0 Überläufe:0 Träger:0
          Kollisionen:0 Sendewarteschlangenlänge:1000 
          RX-Bytes:0 (0.0 B)  TX-Bytes:198841 (198.8 KB)
          Interrupt:19 Speicher:f0600000-f0620000 

and

route -n
Kernel-IP-Routentabelle
Ziel            Router          Genmask         Flags Metric Ref    Use Iface
0.0.0.0         192.168.1.138   0.0.0.0         UG    0      0        0 wlan0
169.254.129.0   0.0.0.0         255.255.255.0   U     1      0        0 eth0
192.168.1.0     0.0.0.0         255.255.255.0   U     9      0        0 wlan0

Then in CUPS a new Printer with URI = "socket://169.254.129.130"

Thanks to mecks52 and Class Stacker.

:-joerg

  • It should be pointed out that the only required action is to setup the printer and computer with their specified static IP addresses, and network mask, then make sure that both device's are enabled. the ifconfig and route (and also ping) commands are only for validation, no config files to edit. – Yanick Rochon Feb 2 '16 at 18:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.