0

Most of the threads I've found relating to this problem state that the machine powers up but the screen remains black. Not so in my case.

The problem I am experiencing is this. When testing the Suspend, everything works as expected. Computer enters sleep and I can resume from USB. But testing is usually for a short duration. When I leave the Computer in sleep for any length of time (shortest I've noticed but may be less is 1 hour) it will not wake up or power up. I do notice the LED on my case fan flash once, but other than that there is nothing. So, of course, there are no error logs.

In addition to this, the reset button does not work neither does holding the power button. I have to physically cut the power, after which I can do a normal reboot.

I'm on a clean install of Ubuntu 14.04, with a Radeon HD6790 graphics card. Thinking it may be related to the graphics card I've tried both the Catalyst v.12 and the beta v.14.

All I can think is that it must be some setting used to enter Suspend which is causing the problem.

Can anybody suggest a way to remedy the problem or something else I can try?

closed as off-topic by bain, Eliah Kagan, RobotHumans, Eric Carvalho, Luis Alvarado Aug 6 '14 at 23:08

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Bug reports and problems specific to development version of Ubuntu should be reported on Launchpad so that developers can see, track and fix these issues." – bain, Eliah Kagan, RobotHumans, Eric Carvalho, Luis Alvarado
If this question can be reworded to fit the rules in the help center, please edit the question.

  • I was also having a similar issue, this is a bug as mentioned by Bain in the answer. You should report this issue so future versions for your specific case can be solved. Good day Waldermort ^^. – Luis Alvarado Aug 6 '14 at 23:08
1

This is a bug and should be reported it on Launchpad. You will then be asked to:

Even if the bug is fixed in later mainline Linux kernels, it is still important to report the issue on Launchpad to ensure that the bug gets fixed in the Ubuntu kernel.

  • I've just been reading the DebuggingKernel link. Trouble is I have to wait a long time while PC is sleeping to see the problem. All I can do is sleep using the given command and try in the mornings. – Twifty Aug 5 '14 at 11:40
  • Yes, debugging these kind of intermittent faults requires time and patience. What make/model system is this? Does the BIOS have any "deep sleep" or other sleep related features? Does the issue still occur if you suspend from a text only boot (add "text" to the kernel parameters in grub)? If this is a desktop you can also try swapping out hardware components to try and narrow down exactly which component triggers the fail (most likely would be the motherboard, GPU). Also try a serial console if you can, the kernel might be trying to print an error but if GPU fails you can not see it. – bain Aug 5 '14 at 11:50
  • Well, just booted into the latest kernel and I have no desktop or any terminal or keys. Had to hit the reset button :/ To answer your question, there is nothing special in the BIOS and it's updated. I'll just keep putting the machine to sleep using pm_trace and hopefully I can at least confirm it is the GPU. I'll report these two bugs and hopefully they have a solution waiting for beta testing. – Twifty Aug 5 '14 at 12:15

Not the answer you're looking for? Browse other questions tagged or ask your own question.