1

I am running dual-boot with Ubuntu 14.04 and Windows 8.1. Everything works great without needing to live boot... except one problem I can't figure out. Every time I boot into Windows, it rearranges the boot order to what appears to be default settings. Let me clarify, if I boot into Ubuntu and restart, then I go to the Grub menu. But if I boot into Windows and restart, then I go straight back into Windows. When this happens I immediately check the BIOS and find that all settings are the same as I left them except the boot order has been rearranged as previously mentioned.

Can anyone explain why this happens or how to stop it? I tried changing the "default operating system" through windows control panel but, of course, only Windows is recognized and listed as an option. For the time being, I set the POST messages to display and delay 20 seconds so I can go straight to BIOS, change the boot order, and boot Ubuntu from there instead of starting Windows and rebooting. But I would love to have my GRUB menu working properly. By the way, I'm very new to Linux, scripting, etc, so please don't expect me to understand a lot of jargon. I only know the bits and pieces I've introduced myself to as need be.

Thank you all for your time and assistance in this matter.

1

The cause of your issue could be that you are booting the EFI default bootloader of the harddrive instead of the Windows bootloader (NVRAM entry named Windows Boot Manager), which usually "corrects" the boot order. Just use the Windows bootloader in that case, alternatively you could replace the default bootloader with another one.

  • I didn't know there were multiple boot loaders or replacement ones. I'll do some research on the matter and check it out. Thank you for your help. – user241564 Aug 6 '14 at 14:57
0

Have you turned off secure boot in boot menu?.That might be the problem.Also turn off the fast start up from control panel.

  • Could you edit your answer to explain how you do this? – Tim Aug 5 '14 at 12:57
  • Kumaran - Yes I did turn off fast start up from control panel and secure boot in BIOS. Also, while in BIOS I found another option for fast start and disabled that as well. I ran Boot-Repair and it can find no problem. – user241564 Aug 5 '14 at 18:48
  • Kumaran - By the way, I also have "Legacy Support" disabled. Is that supposed to be disabled? Enabling it doesn't seem to change anything. I read up on it a little bit and frankly I'm not sure I fully understand it. – user241564 Aug 5 '14 at 19:17
0

Tim - Are you asking how to change secure boot and fast start up? For fast start up: Go to your control panel and open the "Power Options" folder. You should have a selection on the left that says "choose what the power button does". Click this option. On the next screen you should see an option near the bottom that says "Turn on fast startup (recommended)". If you want to turn it off, obviously just uncheck the box. If you cannot uncheck it then look for an option on that page that says "Change settings that are currently unavailable". Clicking this option should make the fast startup option changeable. As for the secure boot: Hold down "shift" while restarting the computer. A menu screen will open. Click "Troubleshoot" > "Advanced Options" > "UEFI Firmware Settings". It should restart into your BIOS menu. The arrangement of your BIOS options will depend on your system but it should be pretty easy to find "Secure Boot" and disable it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.