5

I have Ubuntu 14.04 on what used to be a Windows 7 laptop. I have no partition. Windows is absolutely gone. When I first got Ubuntu, I was thrilled to hear that I can get my beloved GIMP.

However, every time I would try to start it, it would load for a few seconds and give me that blue splatter saying it crashed, asking me if I want to relaunch or send an error report. It would always do that. I just left it alone. I REALLY need to use GIMP right now because it is my best choice for what I have to edit, and it still does not work.

Earlier today, it gave me that blue splat a couple times and relaunch obviously does not work. My cursor just loads for 10-20 seconds and nothing happens. Now, I am not even getting an error. The cursor just loads for 10-20 seconds and stops. I uninstalled GIMP and reinstalled it twice today, and no more error message. It just loads and stops.

I have no idea what to do. I need GIMP and I do not even know what the problem is. I only have this computer. I am really hoping someone can help me. If I were still getting that error report, I could tell you the details, but I am not getting anything anymore but a few seconds of loading.

Also, if you are going to walk me through the steps and know how to fix this, please dumb it down as much as possible because I am not very familiar with Ubuntu like I am with Windows. Ubuntu is just upsetting me so much lately with all this trouble it gives me.

EDIT: Well, excuse me for not giving you enough details, but I did state that I have no idea why it is doing this and I was not getting an error message. When I type "gimp" into terminal, I get:

"Segmentation fault (core dumped)"

I have reinstalled GIMP many times. I have tried from both the website and the Software Center. The current, broken version on my computer is directly from the Software Center. And before someone asks, I purged before reinstalling each time.

EDIT: I ran a memtest, and it passed with no errors.

EDIT: It opened in Guest... can someone please explain that?

  • 1
    Try renaming the .gimp-2.8 folder in your home directory to .backup-gimp-2.8 or something similar. Then try restarting gimp again. – Mitch Aug 5 '14 at 5:22
  • Giana, how;d you go about installing GIMP? Did you simply open the Software Centre and install it from there? Or have you tried downloading a package from the internet and installing it like you'd install something in windows. – amanthethy Aug 5 '14 at 5:38
  • 2
    Could you open a terminal window and type "gimp", what happens and what is the message? – Jacob Vlijm Aug 5 '14 at 6:41
13

The problem is that gimp failed to create the gimp-2.8 directory in your /home/user/ directory. Just create the hidden directory this way;

mkdir .gimp-2.8

and then start gimp

  • thanks man! i have been searching for a solution since 14.04 was released ! – Senad Uka Oct 28 '14 at 13:49
  • 5
    What the heck caused this issue? What cruel thing must happen to gimp, that it segfaults because a folder is missing it could have created? – Mitja Apr 19 '15 at 17:58
  • what's really nuts about this answer is that I've been running gimp just fine for months on 14.04, and today it stopped working. then I doubtfully tried this answer, and it fixed it! thanks!! – Jeff Puckett Aug 7 '16 at 2:26
0

If you installed GIMP from a package you downloaded from the net, the first thing you'll want to do is uninstall that. To make sure we remove it and any config files it may have tried to create we're going to uninstall it from the terminal. Press Ctrl+Alt+T to open a terminal. Then type sudo apt-get purge gimp and press Enter. Once that's done, open up the Ubuntu Software Center and search for GIMP and install it from there by clicking on install. That should fix things.

You may have already installed it through the correct channels. If you did, and its not working still, open the terminal again Ctrl+Alt+T and then type gimp and press Enter. If it spits out any errors or warnings, paste those in your original question.

  • I have done all of that, but thank you. – Giana Jinx Aug 5 '14 at 22:38
  • A seg fault means that there's a serious bug in the version of GIMP you're trying to install which is causing it to fail irrevocably. We could try installing a newer version through a PPA. – amanthethy Aug 5 '14 at 22:44
  • Could you try opening a terminal and pasting sudo apt-get purge gimp && sudo add-apt-repository ppa:otto-kesselgulasch/gimp-edge && sudo apt-get update && sudo apt-get install gimp gimp-gmic gmic && sudo reboot – amanthethy Aug 5 '14 at 22:47
  • I did it all and I got an error as soon as I turned on the computer than GIMP "unexpectedly had to close". The details told me that it was a crash and this error is usually associated when a program is not installed anymore. – Giana Jinx Aug 5 '14 at 23:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.