1

I have an issue that I cannot seem to solve, please see the following screenshot:

The circles represent the key symbols which aren't removed even during live session from a bootable USB of Xubuntu.

What I'm trying to achieve is to move the unallocated space all the way to the bottom so I can merge it with sda7.

I already tried all sorts of techniques of resizing and what not, it simply doesn't allow me to move that partition, it won't get past sda4.

  • I can't see the screenshot since the image sharing site is blocked by a campus firewall. Try imgur. That said, I assume you are talking of GParted here. You can right click the partition in GParted and click on Unmount to unmount the partition, after which you should be able to make changes. – muru Aug 5 '14 at 3:39
  • @muru tried that also, didn't work. All I could change were flags. – Inoki Aug 5 '14 at 6:35
  • No option to resize? – muru Aug 5 '14 at 6:40
  • @muru even though I went through the live session the extended partition which holds /, swap and /home is locked and I can't unlock it. – Inoki Aug 5 '14 at 6:53
  • 1
    Just to be certain, you can't unlock any partition within the extended partition? sda4 can't be unlocked if any partition within it is mounted. And on live session, the swap gets enabled, which would make sda6 and hence sda4 locked. – muru Aug 5 '14 at 7:04
0

An extended partition is locked whenever any logical partition within it is mounted. In a live session, swap gets automatically enabled, so the swap partition (in this case sda6) will be mounted. Hence sda6 and consequently sda4 become locked. To unlock an extended partition, you have to unmount the logical partitions within it by right clicking them and choosing Unmount (or Swapoff in the case of swap partitions).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.