1

I have an HP Office Jet Pro to which I am trying to network print. All jobs that I send to it never print and if I check with the Document print Status window, the status is listed as processing. I could print things about a year ago but not any more.

Things I have tried:

  • Restarting my computer.
  • Restarting the printer.
  • Checking to make sure I have the right IP address.
  • Pinging the printer's ip address. That does work.
  • Trying to "add" the printer a second time.

I have ensured that, under printer policies, the "Enabled" check box is checked.
I tried setting up printing from a windows virtual box inside my Ubuntu machine. I was able to print part of a test page, though it also gave me an error message.

I will add that my office mates are able to print to this computer using different computers.
I can print to other printers on my network.

Any suggestions?

  • Anybody? I still have this problem and it seems pretty mysterious to me. – ohnoplus Sep 3 '14 at 18:49
1

Things seem to have sort of magically started working, when I made a new connection to the printer. I did the following:

  • Opened Printers from dash
  • Added a printer
  • Clicked Find network printer
  • Entered the printer's ip address in the host box and clicked find
  • Under connection, selected HP Linux Imaging and Printing (HPLIP)
  • Proceeded through the rest of the add printer steps following the prompts.

The connection that got created seemed to work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.