1

So I have a fairly new (two weeks old) Ubuntu installation (14.04 x64) and it looks like Suspend mode does not work...

When I click System -> Suspend the screen goes black for about one seccond and then everything comes back to normal, and my wifi is reconnecting. No error message ever comes either.

I tried it on another laptop (an old netbook x86, Acer) and it worked as expected on that one, even automatically suspended when I closed the lid.

Any tips for solvig this really annoying problem? I am still used to just closing the lid when I leave my computer for a few hours as I was using Windows since recently, but now when I come back I'm finding my battery almost drained.

1

I just found what was causing it. Finally!

The problem was that I had installed xboxdrv in order to use my twin gamepad in games. It didn't work, and it soon turned out that I didn't need that driver anyway since Steam can map the controls all by itself, so I removed it.

However, I just found that there are some files left over, and one of them was causing my suspend issue. It was /etc/pm/sleep.d/xboxdrv. I just opened that folder as root and moved the file to another location, and voila, the suspend function works.

I hope that my "discovery" will be useful to others.

0

I have had this issue with both pm-suspend and closing the lid - except for in my case the wake up would happen 50-90 seconds after suspend. Just long enough for me to have stuffed the laptop in my bag where it has no chance of cooling itself.

After lots of searching, and even writing a work-around program which would invoke "pm-suspend" when the lid was closed I found that something other than the lid could wake up the machine:

root@host:~# cat /proc/acpi/wakeup
Device  S-state   Status   Sysfs node
P0P2      S3    *disabled  pci:0000:00:01.0
PEG1      S3    *disabled
EC    S3    *disabled
GMUX      S3    *disabled  pnp:00:07
HDEF      S3    *disabled  pci:0000:00:1b.0
RP03      S4    *disabled  pci:0000:00:1c.2
ARPT      S4    *disabled  pci:0000:02:00.0
RP04      S4    *disabled  pci:0000:00:1c.3
RP05      S3    *disabled  pci:0000:00:1c.4
XHC1      S3    *enabled   pci:0000:00:14.0
ADP1      S3    *disabled
LID0      S3    *enabled 
root@host:~# echo "XHC1" > /proc/acpi/wakeup 
root@host:~# cat /proc/acpi/wakeup
Device  S-state   Status   Sysfs node
P0P2      S3    *disabled  pci:0000:00:01.0
PEG1      S3    *disabled
EC    S3    *disabled
GMUX      S3    *disabled  pnp:00:07
HDEF      S3    *disabled  pci:0000:00:1b.0
RP03      S4    *disabled  pci:0000:00:1c.2
ARPT      S4    *disabled  pci:0000:02:00.0
RP04      S4    *disabled  pci:0000:00:1c.3
RP05      S3    *disabled  pci:0000:00:1c.4
XHC1      S3    *disabled  pci:0000:00:14.0
ADP1      S3    *disabled
LID0      S3    *enabled 
root@host:~# 

After this, pm-suspend worked (did not wake up again after a few minutes) and the lid did too.

Since the wake-up happened only a few seconds after the light in the keyboard (it's a macbook pro) went out - I assume the culprit "XHC1" must be the keyboard - which also explains that if I suspend with pm-suspend I cannot wake it by hitting normal keys, only the power button.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.