I use Skype for Ubuntu , but there is a problem: I cannot send and receive sound.

When I open the Skype's options window in the Sound Devices it says that in all (microphone, speakers and ringing) I use a virtual device. I think this is where the problem is, so, could you please help me?

Also, I do not use the original Ubuntu, I use Lubuntu.

  • Do you have pulseaudio installed/running? Skype 4.3 now relies on pulseaudio for audio input/output.
    – hal7df
    Aug 5, 2014 at 4:17
  • 1
    So should I use the command "sudo apt-get install pulseaudio"? Aug 5, 2014 at 7:12
  • Try it, it should work :)
    – Tim
    Aug 5, 2014 at 10:59
  • And then pulseaudio automaticaly runs, or should I do something more? Aug 7, 2014 at 12:59
  • related for Ubuntu: askubuntu.com/questions/506259/… Jan 23, 2016 at 22:50

6 Answers 6


Skype 4.3 needs PulseAudio, so I recommend you to install Pulse Audio Volume Control (pavucontrol) from the Lubuntu Software Center. or try:

sudo apt-get install pulseaudio 

Then it will be opened if you make a right click on the volume icon and choose volume control settings. It has a tab called recording where Skype will be shown if "Show Applications" is chosen while you are making a call, for instance a test call. It ought to show your microphone is working.

More instructions are described in this support webpage of Skype for Linux.

  • 1
    +1. PulseAudio seems to need a reboot to detect available in- and output hardware. Jun 5, 2015 at 9:37
  • I can confirm this works (google is awesome). May 3, 2016 at 0:01

For all others who stumble upon this post looking for a solution to this problem and aren't very Linux/Tech savy just like me, this was my solution and I'll try to explain it as simple as possible.

I run Lubuntu 12.04, and I had the same problem. As the others mentioned above, Skype 4.3 no longer supports the ALSA sound driver (Too bad! I really hope they bring support back for ALSA! I personally like ALSA quite a bit better than PulseAudio.) and now solely relies upon PulseAudio as it's audio driver. As far as I'm aware Lubuntu (at least Lubuntu 12.04) doesn't come with PulseAudio, so you'll need to install that yourself. I used this code to do so:

sudo apt-get install pulseaudio

Copy that into the LXTerminal (located in the "start" menu - Accessories) and press Enter. Once the process finishes, PulseAudio should be installed and you can check to see if your Skype audio is working now.


install this and it works :)

sudo apt-get install gstreamer0.10-plugins-ugly gxine libdvdread4 totem-mozilla icedax tagtool easytag id3tool lame nautilus-script-audio-convert libmad0 mpg321 gstreamer1.0-libav
  • apt-get install puleseaudio should do the trick...
    – einpoklum
    Aug 3, 2015 at 12:51

Skype dropped support for ALSA in version 4.3, which left it unable to discover or use the audio devices that worked in 4.2, unless PulseAudio is installed. If you are among the many users/admins for whom Pulse is not viable, you currently have two options:

  1. Install Skype 4.2 and edit the binary to spoof the version number.

  2. Find an alternative to Skype.

It's worth noting that WebRTC is integrated into recent web browsers, and free video chat services that use it are starting to appear. For example, both of these worked for me today in Chromium:



Good luck!


I was having the same issue. Skype wouldn't play any sound. I'm running Lubuntu 16.04. I followed what it was advised above by a couple of users...

sudo apt-get install pulseaudio 

and now I have audio when I open and make a call using Skype :) . Thanks!


If you haven't found a solution, just use Skype for web - still in beta. It works for me almost as good as google hangouts.

Here are some other good links to checkout:


How do I install Skype?

I've fought with Skype sound not working properly on xUbuntu and Mate over many installations. When mic and audio are working with all my other desktop apps, i'm hesitant to make global adjustments just for a Microsoft product. Mainly because of concerns with breaking other things that are working.

I frequently have to remind myself that being on Linux only makes scene if you have both the configuration freedom and productivity. Chasing down why a Microsoft package doesn't work is just not worth the time for me when I can get what I need from that tool with Skype for web and google chrome.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.