10

My Nox "Krom Kull" mouse will not work (except for the lights) in my laptop when I unplug it and then plug it again in "Ubuntu 14.04".

I have tried with an old "Razer" mouse and that one does work. I also kind of remember this not being a problem a month or two ago, so this could be related to a recent Ubuntu update. And, due to a recent mechanical issue with this mouse, I have been given a new one of the same model that also does not work. The model and an OS update seem to be the best candidate as the source of the problem.

The laptop is an "Alienware m17r4".

Thanks!

  • Try to reboot from the previous kernel version, its most likely caused by the drivers in the recent update. – Moga Aug 4 '14 at 11:53
17

Try reloading the mouse driver with

sudo rmmod usbhid
sudo modprobe usbhid

when the mouse is plugged in and not working.
If it helps, try adding usbhid to the end of /etc/modules file and reboot. This is sort of shamanic as it should make no difference, but often helps with unrecognized thumb drives.
If it does not help, you can create a udev rule to reload the mouse module on mouse plugging.

  • 1
    This works on Ubuntu 16.04 with a GM-04003A XSCROLL Genius Mouse. – Jose Barakat Sep 5 '16 at 19:42
  • 2
    After the first commend ran my USB keyboard was dead. I had to restart my pc from Casing button. If anyone reading this who have usb keyboard be careful! Probably run both of them together sudo rmmod usbhid && sudo modprobe usbhid ( i have not tested this ) – Sisir Jun 16 '17 at 20:46
  • modprob: ERROR: could don insert 'usbhid': Package not installed – Cristiana Nicolae Feb 16 at 8:42
  • Are you still using Ubuntu 14.04 these days? – Barafu Albino Feb 17 at 13:46
1

try this

echo "on" | sudo tee /sys/bus/usb/devices/usb*/power/control

then reboot. it works for me.

  • ( my apologies for asking this two years after -- but that's the first when I saw it ) how comes it works after reboot? To my knowledge, /sys and /proc settings are not permanent – ジョージ Dec 20 '18 at 10:26
  • @ジョージ Maybe rebooting is what makes it work. – Tibo Jan 18 at 13:30
1

This happens because the power management switches off usb devices in order to save power after a certain period of inactivity. Although there are solutions to solve this manually I recommend to install software called tlp.

$ sudo add-apt-repository ppa:linrunner/tlp

$ sudo apt-get update

$ sudo apt-get install tlp

$ sudo tlp start
0

I faced a similar issue when upgrading from 15.10 to 16.04. The mouse would work for 5 seconds and then go into a sleep mode, and wouldn't work again unless I clicked the button. My solution was to uninstall a power-saving package designed for laptops, and then reboot:

sudo apt remove laptop-mode-tools
sudo reboot
0

I had the same problem and the fix was super simple!

Go to System settings -> Setting Editor

Then you get a dialog window, in the left select "pointers", search for the virtual mouse, and in "properties" you get a "Device_enable" with value 0. Change the value to 1 and then you are done!!

Let me know if it works!

  • I don't see the 'Setting Editor' under System Settings – Shoan Jul 28 '17 at 6:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.