4

I have ubuntu 14.04, and am using lightdm. I want to login to the machine from another (windows) computer using VNC. By using the following /etc/lightdm/lightdm.conf I get a VNC server, but when I try to connect to it I get (using chrome realVNC or TightVNC client) an error 'Authentication reason: No password configured for VNC auth'

[SeatDefaults]
autologin-user=
user-seesion=ubuntu
greeter-session=unity-greeter
allow-guest=false
[XDMCPServer]
enabled=true
port=177
[VNCServer]
enabled=true
port=5900
width=1360
height=768
depth=24

I have used vncpasswd on the machine to set a password. However this is a password for a specific user (I think). Also 'update-alternatives --list Xvnc' points to:

  • /usr/bin/Xvnc
  • /usr/bin/Xvnc4
4

A little bit late, but here is how to configure a password for lightdm integrated vnc :

# vncpasswd /etc/vncpasswd

# tail /etc/lightdm/lightdm.conf
[VNCServer]
enabled=true
command=/usr/bin/Xvnc -rfbauth /etc/vncpasswd
port=5900
width=1280
height=1024
depth=24

and restart lightdm

0

This may be helpful for you: https://answers.launchpad.net/ubuntu/+source/lightdm/+question/209394

I'm attempting to set this up now, I'll post an update if I get it to work.

  • Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. – hg8 Oct 1 '15 at 13:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.