4

I am trying to use ibus-pinyin to input Chinese; but, I am having a problem.

The ibus input method always gives me unexpected Chinese characters.

For example, if I type "zhongwen", it doesn't give me the two characters "zhong" and "wen" as expected, but instead gave me “zang ongwen” (脏 ongwen). I can't find any place to choose the characters I want to use.

I tried to change the different Pinyin method such as double Pinyin and others, but all of them gave results like this.

Could any one help resolve my issue?

1

Is it similar to Why my ibus input can't type 'que' or 'qve' in Chinese? ? It solved my problem (deactivating the low frequent character in the dictionary).

0

I had this exact same problem and really don't understand how that pinyin input works and why it does that. Using a different pinyin input fixed the problem for me:

sudo apt-get install ibus-libpinyin

Add Chinese - Intelligent Pinyin as input method and remove the normal Pinyin input method

Go to the settings for this input method and change pinyin mode to full pinyin.

0

There are three steps to solve this problem to me:

1.ibus-setup

2.Remove 'Pinyin' in the 'Input Method'

3.restart ibus and pinyin

 ibus restart
 pkill -x -u wang ibus-engine-pinyin

protected by Sergiy Kolodyazhnyy Feb 4 at 3:12

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.