0

I followed these instructions to install ubuntu on my computer which already has windows 8, I chose to burn it on a DVD. My computer is an Asus X550CC.
It didn't work, my computer simply restarts without doing any of the stuff it is supposed to do.
I look it up and it seems to be because I have windows 8 and it uses UEFI and not BIOS. I look for a solution.
I then see those instructions. I write them all down to follow them when I try again.
Turns out my computer does something completely different. So I try to find the equivalents and disable the things that look like they should be disabled. I click on the boot override that corresponds to my DVD. It brings to the menu where I can click "test ubuntu" or "install ubuntu".
I click "install ubuntu", follow the steps until the step where I must choose the "installation type".

That is where it says "This computer currently has no detected operating systems.". Which is obviously not true as I have windows 8 and I don't want to delete it.
Why can't it detect windows ? What can I do to make it detect it ?

I stop everything and go back to google and that is where I reach my limit because, I don't understand anything of what I find.
You see I understand that this problem has been stated many different times on askubuntu but I do not understand the answers.
What you need to know is that I don't know the first thing about computers. What I can do is follow instructions, however something always went wrong at some point and I can't improvise. The answers I have read said stuff about backing up things, and partitions and stuff, and I couldn't understand even half of the instructions in the answers.

It would mean a lot to me if someone took the time to explain to me what I need to do in a very detailed manner with lots of images so I know what I'm looking for, because I am lost here (sorry for the long text, but I tried to "trace my steps" for you because maybe I did something wrong but I didn't know that I shouldn't have done it).

  • If you installed with purple screen you booted in BIOS mode and how you boot is how you install, so you installed in BIOS mode. You have to turn UEFI off in UEFI/BIOS to boot Ubuntu and turn UEFI on to boot Windows. Better to have both systems in same boot mode. Currently major bug in installer in it does not see Windows 8. I blame Windows. But only safe way is full backup of Windows and only use Something Else install option.askubuntu.com/questions/221835/… and:help.ubuntu.com/community/UEFI – oldfred Aug 3 '14 at 23:41
  • I did not have a purple screen (well the loading page was purple, then the menu was black, I assume you are talking about the menu?), so are you saying I should have a purple screen or I shouldn't ? I was afraid I would have to use something else because I don't really understand how do it, I'll try to read in depth the pages you linked and see if I can do what they say. I might take some time. – Eibi Aug 4 '14 at 0:56
  • @oldfred and I both thought you got the first pic in my answer, which comes after something like this image: i.stack.imgur.com/GtEi5.png However, since Windows 8 wasn't detected even with UEFI booting, you might have to go with manually partitioning and installing Ubuntu, and then adding a GRUB menu entry for Windows. – muru Aug 4 '14 at 1:02
  • Oh ok. I'll try to see if I am capable of doing that, but maybe tomorrow because it's 3 in the morning for me. Thanks for taking the time to answer my questions. – Eibi Aug 4 '14 at 1:17
0

I see that you have somehow managed to enable "Legacy Boot" in UEFI, since you probably got here: Ubuntu legacy boot

So, what I'd like you to do, is disable it and go back to the previous state. If you UEFI boot with a 64-bit Ubuntu image (DVD), you ought to see a GRUB menu like in this question (the OEM option won't be present, but Try Ubuntu and Install Ubuntu will be.): Ubuntu UEFI boot

To get a 64-bit image, download the AMD64 (or AMD64 + Mac) ISO from http://cdimage.ubuntu.com/releases/trusty/release/. Only the 64-bit version currently supports UEFI, and you are most likely to detect Windows 8 using it, with regular UEFI boot.

  • You're right I had enabled something with Legacy however I've never seen what is in your first picture. I saw the GRUB menu, and then the install window where I choose the language. I checked again, enabled and disabled, and the same GRUB menu shows up (and the OEM option is actually present). And in both cases it still doesn't detect windows. – Eibi Aug 4 '14 at 0:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.