So, I tried creating an OS with VirtualBox, and I got this error:

Kernel driver not installed (rc=-1908)

The VirtualBox Linux kernel driver (vboxdrv) is either not loaded or there is a permission problem with /dev/vboxdrv. Please reinstall the kernel module by executing

'/etc/init.d/vboxdrv setup'

as root. If it is available in your distribution, you should install the DKMS package first. This package keeps track of Linux kernel changes and recompiles the vboxdrv kernel module if necessary.

So I did the obvious, running the Vboxdrv setup. I ran this command:

sudo service vboxdrv setup

I got an error while doing so.:

stopping kernel drivers...done.

Uninstalling old virtualbox dkms kernel modules/etc/init.d/voboxdrv: 302: /etc/init.d/vboxdrv: /usr/share/virtualbox/src/vboxhost/do_dkms: not found
...done.
(Failed, trying without DKMS)
recompiling VirtualBox kernel modules...failed!
(look at /var/log/vbox-install.log to find out what went wrong.)

So, I took a look at /var/log/vbox-install.log to see if I can find anything. I got this error:

/etc/init.d/vboxdrv: 334: /etc/init.d/vboxdrv: /usr/share/virtualbox/src/vboxhost/build_in_tmp: not found

Any help? Thanks.

Finally got this working. Looks like DKMS is not working as it should(?). After reinstalling virtualbox-dkms, my VMs are back up.

sudo apt-get --reinstall install virtualbox-dkms
  • 1
    I say that DKMS is not working as reinstalling virtualbox-dkms returned multiple results like the following: vboxnetflt.ko: Running module version sanity check. - Original module - No original module exists within this kernel - Installation - Installing to /lib/modules/3.13.0-35-generic/updates/dkms/ ... vboxpci.ko: Running module version sanity check. - Original module - No original module exists within this kernel - Installation - Installing to /lib/modules/3.13.0-35-generic/updates/dkms/ – Crusty Barnacle Aug 31 '14 at 21:39
  • This works for me – Ker Ruben Ramos Mar 29 '15 at 18:40
  • 1
    @CrustyBarnacle I am just going through the same issues :o ... it seems that for the virtualbox install I had no 'src' folder so when I ran the setup command it uninstalled my old VB kernel but failed to recompile a new one (same as yours) - this is why "no original module exists" error is coming up - BTW my issues started just after I did the latest ubuntu update of the day.... hmm... related? – code_fodder Dec 17 '15 at 8:12

I would suggest the following:

First, ensure that you have the headers and other required elements to build programs. Open a terminal window ctrl+alt+t

sudo apt-get install build-essential libssl-dev linux-headers-`uname -r`

Secondly, install the dkms module so that you do not face this problem after kernel updates

sudo apt-get install dkms

Finally, try the command as suggested by the first error message

sudo -i
/etc/init.d/vboxdrv setup
exit
  • Hello, thanks for your reply. I get the same error message I lastly said. Any suggestions? – user287210 Aug 3 '14 at 20:25
  • @user287210 No, at this point I would uninstall / purge the virtualbox program and reinstall it - do you know which version you have? – Charles Green Aug 3 '14 at 22:58
  • I either installed it with sudo apt-get install virtualbox vityualbox-dkms dkms, or I installed the installer from the oracle website. I heard installin it from the website does people good, so I'm going to purge whatever I have and reinstall from website and I'll tell you what happens. – user287210 Aug 4 '14 at 10:17
  • xfce ubuntu 14.04, I purged the packages and installed VirtualBox from virtualbox.org/wiki/Linux_Downloads , the AMD64 for 14.04. I installed it with a debi package installer. The virtualbox version I installed was 4.3.14. I opened up VirtualBox and I got the same error that suggested I use the vboxdrv setup. I did the setup and I got the same error I did last time i did it. – user287210 Aug 4 '14 at 10:29
  • I poked through a bunch of similar problems - You seem to be on the right track - is the output in the logfile /var/log/vbox-install.log different than before? Is your OS version fully updated? – Charles Green Aug 4 '14 at 15:39

Use "All distributions - run Installer" (bottommost entry of this list) instead of a deb or rpm package! This fixed the error for me (Ubuntu 14.10 + VirtualBox 4.3.26).

  • This solved all my issues..... once I had purged the broken virtualbox :( – code_fodder Dec 17 '15 at 8:27

After trying @Crusty_Barnacle and @Charles_Green solutions without success, I made sure my distro (Ubuntu 14.04) was fully up-to-date then did:

aptitude purge virtualbox virtualbox-dkms virtualbox-qt
aptitude install virtualbox

And everything worked fine again.

Hope this may help others.

protected by Community Jul 2 '15 at 3:47

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.