5

I update and upgrade my ubuntu 14.04 server. Update is successfull but i get this error while upgrading :

apt-get upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
1 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] y
Setting up udev (204-5ubuntu20.3) ...
 * udev requires hotplug support, not started
   ...fail!
invoke-rc.d: initscript udev, action "restart" failed.
dpkg: error processing package udev (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 udev
E: Sub-process /usr/bin/dpkg returned an error code (1)

How can I solve this?

3
  • Please run export LC_ALL=C and run the command again, now with english messages - and edit your answer with it. Aug 4, 2014 at 1:00
  • It's done, in english now,
    – Nick
    Aug 4, 2014 at 8:30
  • Did you solve it? I have same problem.
    – Daniel
    Jan 6, 2015 at 21:10

1 Answer 1

5

Same here! 30 minutes of digging and I found this:

$ apt-get download udev
$ sudo dpkg -i --force-confmiss udev_204-5ubuntu20.9_amd64.deb
$ sudo apt-get upgrade

Worked for me. For more info go to Dimitri's comment in Ubuntu's bug tracker.

1
  • Had same problem on VPS, this worked for me, thanks.
    – PeterM
    Dec 15, 2016 at 12:34

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .