3

I am using Dell Inspiron 15R 5521 laptop. It had Ubuntu 12.04 installed at time of purchase. Everything was working fine.Then i installed windows in it and now i have removed windows and installed Ubuntu 14.04 . The problem i am facing is that my touchpad is not detected in it. I searched on google , askUbuntu but could not get solution to my problem. Also i went through this link (https://help.ubuntu.com/community/SynapticsTouchpad) but it did not help. Can you please help me here. Let me know what other information is required here.

Thanks.

  • try with installing sudo apt-get install xserver-xorg-input-all. If it is already installed, purge and reinstall. – user308564 Aug 4 '14 at 7:46
  • I tried that too.It did not work .. :( – Vimal Jain Aug 4 '14 at 15:45
1

My research indicate that your laptop has a SynPS/2 Synaptics TouchPad

Execute the following command

xinput list

You should see a output like the following

⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer            id=4    [slave  pointer  (2)]
⎜   ↳ Logitech Unifying Device. Wireless PID:1025   id=11   [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard           id=5    [slave  keyboard (3)]
    ↳ Power Button                          id=6    [slave  keyboard (3)]
    ↳ Video Bus                             id=7    [slave  keyboard (3)]
    ↳ Power Button                          id=8    [slave  keyboard (3)]
    ↳ USB Camera                            id=9    [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard          id=10   [slave  keyboard (3)]
    ↳ Toshiba input device                  id=12   [slave  keyboard (3)]
    ↳ Logitech Logitech Wireless Headset    id=14   [slave  keyboard (3)]

To enable the touch pad

xinput set-prop [device id] "Device Enabled" 1

You can do a following to check the properties

xinput --watch-props [device number]

You also can try

lsmod 
lsmod | grep mouse (Check the if the touchpad is loaded)

sudo modprobe -r psmouse
sudo modprobe psmouse proto=imps

Also you can take look at following post too.

Touchpad not working on MSi U130 after login in

HTH

  • I recommend xinput --list-props instead to check the device's properties, so the process ends up. – nightcod3r Aug 13 '17 at 8:31
1

Reference: Touchpad under 16.04 not working

Solution #1

  1. Modify the GRUB file with a text editor (nano works too)

    sudo -H gedit /etc/default/grub

  2. Locate this line in the grub file

    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

  3. Replace it with the following:

    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i8042.nopnp"

  4. Save the GRUB file and run the update

    sudo update-grub

  5. Shutdown / reboot for the changes to take effect.

    sudo shutdown -r now


Solution #2

  1. Modify the GRUB file with a text editor (nano works too)

    sudo -H gedit /etc/default/grub

  2. Locate this line in the grub file

    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

  3. Replace it with the following: (ONLY DIFFERENCE FROM SOLUTION 1)

    GRUB_CMDLINE_LINUX_DEFAULT="i8042.reset quiet splash"

  4. Save the GRUB file and run the update

    sudo update-grub

  5. Shutdown / reboot for the changes to take effect.

    sudo shutdown -r now

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.