4

Below the post, last configuration I used, it seems works well.

I've Lubuntu 14.04 installed on my netbook (aspire one ao-532h). I am using it like a desktop with external display and input devices.

After some errors I've recently reinstalled Lubuntu (before, I've also deleted all .* files and directories in my home directory and formatted the root partition).

One of these errors was the system's inability to go in suspend mode automatically. THis despite xcfe4-power-manager-settings being set to do so. There were no problems when suspending manually.

After installation, it seems that the xcfe4 power manager setting icon is not loaded at startup anymore. Despite this suspend mode seems to work well (After some minutes not using the system, it suspended automatically ). I tought that the time was set in xcfe4-power-manager (despite it not being visible).

After installing a few applications (Lyx, netbeans with jdk..) and changing monitor settings (only the external vga enabled with the netbook display turned off) the issue described previously has reappeared:

The monitor goes into suspend and then switches off correctly. But waiting the 15 minutes (I don't understand why I can't set a time to go in suspend/hibernate mode shorter than 15 minutes) ** the system remains on. When disabling the screensaver the message "power manager not authorized" appears.**

Any suggestions?

I've looked for info about this message balloon ("power manager not authorized") and I've done some changes (but not solved the problem): I am able to

1) Run xcfe4-power-manager and its settings icon at startup in these (alternative) methods: - changing to laptomop mode yes in preferences->lxsession predefined app - adding a line in startup application xcfe4-power-manager --no-daemon

2) Enabled Hibernate option adding a file with name /etc/polkit-1/localauthority/50-local.d/com.ubuntu.enable-hibernate.pkla and contents:

[Re-enable hibernate by default in upower]
Identity=unix-user:*
Action=org.freedesktop.upower.hibernate
ResultActive=yes

[Re-enable hibernate by default in logind]
Identity=unix-user:*
Action=org.freedesktop.login1.hibernate
ResultActive=yes

Configuration that works well:

My configuration:

I've installed also:

  • gnome-power-manager, but after I uninstalled it.
  • xcfe4-power-manager-plugin package

I've enabled hibernate modality, with policy file describe up.

In system preferences/disk/device setting: stand-by after 9:20 min**;** apm on,255

xcfe4-power-manager-settings prescribes:

  • in general tab->"Check screen enrgy option" disabled ;
  • ac(equal for battery) tab->sleep pc after 15 min / screen sleep 2 min switch off 3 min
  • extended tab->pc sleep modality Suspend (works well also hibernate); monitor suspend; lock screen if start hibernate or suspend modality enabled

in preferences

  • apps..lxsessions/autostart-> power manager**/screensaver/screen lock **all enabled
  • apps..lxsessions/settings->laptop mode yes
  • apps..lxsessions/core application->power manager:auto; lock screen manager:blank; screensaver:lxlock
  • Now system (And also screen) go in hibernate and stand-by. I've only a question: How reduce time to go in suspend mode? Why I'm not able to set a time shorter than 15 minutes? – mtt Aug 4 '14 at 10:05
  • Solved also "the 15 minutes question": link – mtt Aug 4 '14 at 19:20
  • Please move your answer to a new answer and mark it as accepted. – Cees Timmerman Aug 25 '15 at 20:42
1

On my machine, I was able to have the machine suspend after inactivity by modifying the file /usr/share/polkit-1/actions/org.freedesktop.upower.policy/org.freedesktop.upower.policy and set

<defaults>
  <allow_inactive>yes</allow_inactive>
  <allow_active>yes</allow_active>
</defaults>

I hope this helps

0

Thaddaeus Tintenfisch (thad-fisch) wrote on 2015-01-07:

This problem is triggered by light-locker which locks the user session (VT7) and forwards the user to the unlock screen (VT8). Please read the official blog entry to learn more about how screen locking works.

The result of this functionality is that the user session becomes inactive while the screen is locked. Therefore, the power manager is not authorized to perform certain actions anymore.

Possible solution are:

  • enable late locking (it delays the VT switch, enable it via Light Locker Settings > Automatically lock the session when the screensaver is deactivated)
  • disable automatic locking completely
  • change the according upower policy (comment #14)

Disabling light-locker in the Light Locker Settings enables sleep mode, but if your BIOS lock screen is too ugly, open /usr/share/polkit-1/actions/org.freedesktop.upower.policy/org.freedesktop.upower.policy as root and set <allow_inactive>yes</allow_inactive> to allow suspend and hibernate while the session is locked.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.