13

when my 64bit Ubuntu 14.04 machine "wakes up" after hibernation, windows look like this:

gigantic borders on all the windows

The system is still usable, but it's really ugly and I believe that Linux is beautiful, not only because of its command line, but also because of its GUI. So there must be a solution for this.

I am using a Samsung R780 laptop, Nvidia GeForce GT 330M graphics card, Intel® Core™ i7 CPU M 620. I have a separate swap partition set up and I'm running the x.Org server with Unity 7.2.0 on top. I'm using the evil ;) Nvidia proprietary driver version 331.38, because open drivers don't work for me. Do you need any additional information?

When I restart the x-server and display manager, everything works fine again.

I didn't find anything on the web and I don't have a clue what could possibly cause this problem, so I'm very thankful for any help.

  • was asked and closed before: askubuntu.com/questions/501986/… – noleti Aug 3 '14 at 12:45
  • Sorry for the double post, should I delete my question now? – schrankwand55 Aug 3 '14 at 12:49
  • 1
    Leave it open for now, just wanted to help you with your search. Another related question: askubuntu.com/questions/360598/… – noleti Aug 3 '14 at 12:52
  • Seems like I messed up my compiz configuration when upgrading to 14.04. Thanks to user164089 and this post ( askubuntu.com/questions/360598/… ), I tried resetting my compiz settings and it works. Without the help of noleti I wouldn't have found that answer. Thank you all for your help!! – schrankwand55 Aug 3 '14 at 13:08
  • Can you tell me, how you restart the x-server and display manager? – Aby Oct 8 '14 at 22:00
17

This is a known bug in Ubuntu 14.04 => https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/1292830, please vote for it by clicking the green text at the top of the page that says "This bug affects 69 people, but not you".

A temporary workaround is to go into a system terminal mode, careful with this as you need to know how to get back to the Unity desktop otherwise you will have to restart.

  1. Press Ctrl + Alt + F6 (takes you to system terminal mode)
  2. Press Ctrl + Alt + F7 (takes you back to the Unity desktop)
  • What is really annoying though is that when I am docked the key sequence actually puts it into sleep mode. Would love to know what is happening then. – Elijah Lynn Jan 25 '16 at 18:57
  • Launchpad has issues with upvoting right now. Hope it's temporary... – AlikElzin-kilaka Apr 4 '16 at 5:06
1

Answered by OP in comments.

Seems like I messed up my compiz configuration when upgrading to 14.04. Thanks to user164089 and this post, I tried resetting my compiz settings and it works.

Kudos noleti - I wouldn't have found that answer otherwise.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.