21

I have Ubuntu 14.04.1 and Skype 4.03.0.37. my audio devices are working fine but when I make Skype calls I can't hear the other person neither they can hear me.

when I checked Skype audio settings it showed virtual device as the only option for all devices.

I tried a lot of proposed solutions on the web and nothing helped.

what could be the problem and how can I fix it?
I know there is not a lot of details in the question to help, what extra details do I need to provide ?

Thank you so much.

38

finally solved. I am running a 64-bit machine and a 32-bit Skype, so I just installed the libpulse 32 bit version:

sudo apt-get install libpulse0:i386 is all what was needed to solve the problem

6

I had your problem as well and solved it by installing pulseaudio and it's dependencies (packages paprefs, pavucontrol, pavumeter are not necessary, at least Skype works without them). I restarted Skype, and now it lists "PulseAudio Server (local)" for microphone, speaker and ring tone. Seems like a missing dependency in the skype package.

  • Thank you, this solved my problem. pulseaudio:i386 was already installed. – Marco Sulla Sep 28 '14 at 19:30
  • This was also my problem on 16.04 – Ott Toomet Mar 18 '16 at 2:35
2

In my case, the reason is that I don't use PulseAudio and "as of version 4.3, the ALSA sound system is no longer supported without PulseAudio" (source)

-1

The "solve everything" command from https://help.ubuntu.com/community/SoundTroubleshootingProcedure made it work on Ubuntu 15.10.

Warning: This solution may create problems for users of the other flavors of Ubuntu like Lubuntu.

sudo apt-get update;sudo apt-get dist-upgrade; sudo apt-get install pavucontrol linux-sound-base alsa-base alsa-utils lightdm ubuntu-desktop  linux-image-`uname -r` libasound2; sudo apt-get -y --reinstall install linux-sound-base alsa-base alsa-utils lightdm ubuntu-desktop  linux-image-`uname -r` libasound2; killall pulseaudio; rm -r ~/.pulse*; ubuntu-support-status; sudo usermod -aG `cat /etc/group | grep -e '^pulse:' -e '^audio:' -e '^pulse-access:' -e '^pulse-rt:' -e '^video:' | awk -F: '{print $1}' | tr '\n' ',' | sed 's:,$::g'` `whoami`

Then reboot.

  • @downvoters please explain ;-) – Ciro Santilli 新疆改造中心法轮功六四事件 Jul 22 '16 at 17:54
  • because in Lubunut, it force the user to download whole gnome and other stuffs and will make the distro unstable – Woeitg Jul 23 '16 at 13:59
  • @Woeitg thanks for explaining. Also consider contacting the people who maintain that Ubuntu help page to have it updated. Cheers! – Ciro Santilli 新疆改造中心法轮功六四事件 Jul 23 '16 at 16:34
  • well, in that page it is written that this solution will destroy other flavors, however you didn't copy that info! so there is nothing wrong with the solution provided by help.ubuntu.com – Woeitg Jul 24 '16 at 8:47

Not the answer you're looking for? Browse other questions tagged or ask your own question.