I have Asus X552V with Ubuntu 14.04 64b.

I tried inserting 4GB Transcend SD Card into Card Reader, but nothing happens.

As I was directed to Why does Ubuntu not detect my SD card? this question, I tried doing what it said, but nothing changed.

Then I tried doing sudo fdisk -l and the output was:

Disk /dev/sda: 750.2 GB, 750156374016 bytes
255 heads, 63 sectors/track, 91201 cylinders, total 1465149168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disk identifier: 0x2bfb4dc8

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *        2046   261904383   130951169    5  Extended
Partition 1 does not start on physical sector boundary.
/dev/sda2       261904384  1129629695   433862656    7  HPFS/NTFS/exFAT
/dev/sda5            2048    58593279    29295616   83  Linux
/dev/sda6        58595328   253904895    97654784   83  Linux
/dev/sda7       253906944   261904383     3998720   82  Linux swap / Solaris

Disk /dev/mmcblk0: 1973.2 GB, 1973231288320 bytes
82 heads, 17 sectors/track, 2764682 cylinders, total 3853967360 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00000000

        Device Boot      Start         End      Blocks   Id  System
/dev/mmcblk0p1            8192     7811071     3901440    b  W95 FAT32

So obviously, I can see my SD card here, but it seems strange to me that disk identifier is 0x00000000, and that it took about 2 minutes to get this information. Is it a Ubuntu bug, or could it be a SD Card issue?

Update: I tried the same SD card with my other laptop also running Ubuntu 14.04 and it works with no problem.

When I run GParted with SD card inside, it will never scan all drives, but it will when I remove it. blkid also runs forever with SD Card inserted

3 Answers 3


Panasonic cards are formatted using exFAT. To automatically mount exFAT filesystems, install following 2 packages:

$ apt-get install exfat-utils exfat-fuse



I have run into the same problem, first thinking there must be a "dirty bit" set on the FAT32 formatted SD card after I had removed it without first unmounting it. The card worked fine in my Panasonic DMD-GX1 camera, and mounted fine in Windows 7 with no errors. I ran CHKDSK in Win7, no problems reported. I then used a sector editor to see if the FAT32 "dirty bit" was set. It was not. I then did a Windows 7 "quick format", ejected the card, and then inserted it in the built-in card reader of my Ubuntu 14.04 box (HP Pavillion p6720f) that had previously refused to mount it. It mounted fine. I ejected the card, placed it in the camera, took several pictures, and returned it to the Ubuntu 14.04 card reader. It mounted fine and all the pictures were accessible. I then un-mounted the card, returned it to the camera, and formatted it in the camera. Being careful to turn the camera off, I removed the card and tried to mount it in Ubuntu. Once again, it would not mount. Took it to the Windows 7 box, quick formatted it, and returned to Ubuntu where mounted fine. I repeated taking some pictures, it mounted fine and the picture files were all there. Formatting the card in the camera once again made the card unmountable, even though the card and picture files were readable in Windows 7.

It seems that some cameras formatting routines are not compatible with Ubuntu 14.04, although I don't see any problems at the point were a "dirty bit" is expected in FAT32. As much as I hate to even turn my Windows 7 box on, it seems to resurrect these "unmountable" cards. I have confirmed that formatting with Canon cameras seems to be no problem, but formatting on my Panasonic DMC-GX1 always causes a fail with Ubuntu 14.04.

For what it's worth, maybe this will provide a clue to other people that are formatting SD cards with other types of devices and experiencing mounting problems with Ubuntu 14.04.


You can boot with Live CD to narrow the problem down. If the SD card works in there then this means it's something wrong with your software (operating system, drivers, configurations). If it's now working under Live CD then this means it's a hardware failure in your card reader, does it read other cards well?

  • 1
    No, if it works well (or even if not) in live CD it doesn't mean that it's a hardware failure. May 3, 2015 at 14:02

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .