3

This question already has an answer here:

I am running Ubuntu 13.10 32bit. Since a couple of days Skype doesn't work anymore: "Skype can't connect". It is Skype version 4.2. I know there have been other posts regarding this problem. Here it is suggested to update to Skype 4.3 using the software center. I tried this but as far as I can see it the Skype version on the software center is still 4.2. I tried ot anyway, that is, I first uninstalled then reinstalled Skype via the siftware center. But as expected it is still version 4.2. And there it still does not work. Also I checked this site ... but they do not have a version for Ubuntu 13.10. For some reasons I would not like to update Ubuntu to V 14.04 at this point so I would be happy if someone came up with a solution how to fix this problem on Ubuntu 13.10.

marked as duplicate by Tim, Eliah Kagan, Seth Aug 15 '14 at 2:24

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 1
    Ubuntu 13.10 reached end of life July 17, 2014. You need to reinstall a current supported version. Check this link to see end of life for various versions: wiki.ubuntu.com/Releases – John Kirchner Aug 3 '14 at 11:36
  • 1
    Install Skype 4.3 from my answer and Don't forget you have to delete old Skype 4.2 folder. use cd ~ && rm -r .Skype – αғsнιη Aug 12 '14 at 12:06
  • 1
    possible duplicate askubuntu.com/a/488062/41800 – Tim Aug 12 '14 at 12:16
  • Just install the 12.04 deb of Skype 4.3 from the Skype site. That's what I did. – Seth Aug 15 '14 at 2:23
3

As explained here, skype will no longer support old versions of skype(including 4.2), so you will have to upgrade to version 4.3. Version 4.3 IS AVAILABLE from the software center. Make sure you checked "Canonical partners" in sources list.

  • 3
    Well, I do get Skype from the software center, but only version 4.2. Anyway, I have just tried the command line installation described here askubuntu.com/a/488062/41800 and this worked fine! I have Skype 4.3 now and there are no further problems. – lpdbw Aug 3 '14 at 11:53
  • @lpdbw: Then you have probably not updated: sudo apt-get update – Gunnar Hjalmarsson Aug 3 '14 at 16:32
1

I upgraded to version 4.3.0.37 because version 4.2.0.13 was not allowing me to login anymore with the error “Can’t connect”.

Unfortunately for me after hours of trying I could not get pulseaudio to work on my system, only ALSA is working so I downgraded back to 4.2.0.13

To solve the login error I spoofed the version number 4.2.0.13 to the latest 4.3.0.37 version and login was working again, problem solved.

So to solve your problem simply downgrade back to 4.2.0.13 and spoof to 4.3.0.37 version, exit Skype and run this command:

sudo sed -i "s/\x34\x2E\x32\x2E\x30\x2E\x31\x33/\x34\x2E\x33\x2E\x30\x2E\x33\x37/g" /usr/bin/skype

  • That worked perfectly... so I can stay on 13.10 for a little longer. (there are reason why upgrading is not always the best solution... unfortunately) – Alexis Wilke Aug 26 '14 at 5:49
  • Weird... I tried to use Skype today and it fails now. 8-( – Alexis Wilke Sep 23 '14 at 2:39

Not the answer you're looking for? Browse other questions tagged or ask your own question.