Wifi will repeatedly cut out after an undetermined amount of time.

I've read the Unstable wireless connection in Ubuntu 14.04 but I don't want to disable N mode b/c I want the faster speed.

I have this card: http://www.intel.com/p/en_US/support/highlights/wireless/cwn-1030

I also tried turning off power management but that doesn't work either

sudo iwconfig wlan0 power off

I ran the wifi script

wget -N -t 5 -T 10 http://dl.dropbox.com/u/57264241/wireless_script && chmod +x wireless_script && ./wireless_script

Here are the results: http://pastebin.com/1AdPQy7D

  • If you tried everything in that other post except the commands that were specific to the driver in that post then N speed being disabled is the last step, because I think there is still a bug that is not allowing new drivers to be built on the newer kernel. N speed most of the time has to be disabled until the driver gets better but it does depend on the router you are using. – Wild Man Aug 3 '14 at 16:03
  • Here is a link that may help without disabling N speed. askubuntu.com/questions/503128/cant-connect-to-wifi14-04/… – Wild Man Aug 3 '14 at 16:07

There may be some code missing in the kernel. See the following "LTR patch". Updating to the patched kernel may be the solution. (See here for an example how to do this.)


See: LTR Patch

[PATCH] iwlwifi: configure the LTR

"From eaf90486817fd0c3de2c65d51e9f2841ec352624 Mon Sep 17 00:00:00 2001

From: Emmanuel Grumbach Date: Tue, 23 Sep 2014 23:02:41 +0300

Subject: [PATCH] iwlwifi: configure the LTR

The LTR is the handshake between the device and the root complex about the latency allowed when the bus exits power save. This configuration was missing and this led to high latency in the link power up. The end user could experience high latency in the network because of this."


None of the solutions above worked for me.

In "network Connections" configuration, for my wifi, in "IPv6 settings", I simply selected "Ignore".

Since then, no disconnections. I hope that help others

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.