9

I am trying to install bluez 5.2 libraries on Ubuntu 12.04. while running ./configure, I received error for GLib2.0, I was able to resolve by using sudo apt get-install for GLib2. Now I am receiving the error "configure: error: D-Bus >= 1.6 is required". I have downloaded DBUS 1.8.6 and installed. but still I am receiving the same error. when checked in /etc folder i still find dbus-1. is there any installation error?

6
  • Is there any reason why you need to compile bluez from sources? Did you tried just sudo apt-get build-dep bluez and compiling? Which version of Bluez are you trying to compile? Edit your question and include the complete output of ./configure.
    – Braiam
    Commented Sep 22, 2014 at 14:07
  • I am trying with bluetooth programming in Linux as a for my curriculum project.
    – padma_uma
    Commented Sep 23, 2014 at 16:52
  • 1
    You probably need libdbus-1-dev or libdbus-c++-dev or something like that.
    – muru
    Commented Sep 25, 2014 at 1:30
  • I am trying to enable bluetooth (Ubuntu Version 13.10), in system settings and seeing this message "No Bluetooth Adapters found:
    – padma_uma
    Commented Sep 28, 2014 at 13:14
  • You need to install the headers, the -dev packages
    – Panther
    Commented Oct 1, 2014 at 15:08

3 Answers 3

18

Installing libdbus-1-dev fixed it for me.

10

Install the headers and libraries required for Bluez compilation:

sudo apt install libdbus-1-dev libudev-dev libical-dev libreadline-dev

For more info: https://codeyarns.com/2017/06/05/how-to-build-and-install-bluez/

-1

Sorted out this problem. First of all I ran

sh -x ./configure 2>errors.txt

The errors.txt showed me what command was failing which was

/usr/bin/pkg-config --short-errors --print-errors --cflag --libs 'dbus-1 >= 1.6'

After further digging it seems a file dbus-1.pc was not where it was supposed to be

After locating the file and copying to the correct location

/usr/lib/pkgconfig/

Hope this helps

2
  • Hi, Can i know from which path i need to run sh -x ./configure 2>errors.txt ?. I have logged in as root
    – padma_uma
    Commented Sep 28, 2014 at 13:16
  • Hi all, Thanks for your suggestions and help. I am able to install Blue-z libraries. The actual problem i was facing "Bluetooth Adapter not found", was solved by switching back to windows and turning on bluetooth adapter in Windows.
    – padma_uma
    Commented Oct 8, 2014 at 11:25

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .