After a restart my menu bar and launcher were missing. I have tried every solution for this issue that I can find, from re-installing unity and compiz to resetting Unity and everything.

Then I decided to reinstall Ubuntu 14.04 without formatting and still had the same problem.

When I run unity I get Error: Plugin 'opengl' not loaded.

What can I do?


1 Answer 1


first run

dpkg -l | grep opengl

This will tell you what opengl accelerators are installed on your system.

To search available packages, the following . . .

apt-cache search openGL | grep plugin

. . . results in a few interesting results.


compiz-plugins-default - OpenGL window and compositing manager - default plugins compiz-plugins - OpenGL window and compositing manager - plugins

Try running

sudo apt-get install --reinstall compiz-plugins-default compiz-plugins compiz-plugins-extra compiz-plugins-main compiz-plugins-main-default compizconfig-settings-manager

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.