This machine have 2 128 GB SSD drives (http://www.amazon.com/dp/B00EPGHE0E/ref=twister_B00JYFOKKS).

I managed to install Ubuntu with no problems on one SSD drive, but I am having following troubles with RAID setup. Here is the details:

  • I boot from live USB (try Ubuntu option).
  • Install mdadm: sudo apt-get install mdadm.
  • Create RAID:

enter image description here enter image description here

  • Run installer:

enter image description here

  • It fails to install GRUB:

enter image description here

I also tried to install grub manually after installer failed:

  • I looked how RAID is partinitioned:

enter image description here

  • Added BIOS Boot partinition:

enter image description here

  • Tried to install GRUB:

    $ sudo mount /dev/md127p4 /mnt

    $ sudo mount /dev/md127p1 /mnt/boot

    $ sudo grub-install --root-directory=/mnt /dev/md/127

    Installing for i386-pc platform.

    grub-install: error: diskfilter writes are not supported.

  • Tried solutions proposed in Diskfilter writes are not supported > What triggers this error? but still same error.

UPDATE:

I tried with alternate install image, following this video https://www.youtube.com/watch?v=-x2rZe2Z9as, but, after reboot there are no boot options, BIOS opens without any boot option. I had a boot partition on /dev/sda, GRUB was installed on it, but was unable to boot for some reason.

  • I'm mostly curious why you would want to create a raid0 with 2 SSD drives increasing the risk of data failure with 100% Isn't it fast enough with the disk being an SSD already? – tomodachi Aug 15 '14 at 15:12
  • @tomodachi I have 2 SSDs and want to take advantage. I guess same thing happens with raid1. – umpirsky Aug 21 '14 at 9:14
  • No, raid1 will increase the redundancy of keeping your data. If one disk dies, your data will still be safe. With raid0 if one of the disk dies all your data is gone – tomodachi Aug 21 '14 at 9:37
  • @tomodachi That's fine for me, I don't care about data that much, I prefer performances. Risk of data loss with raid0 is same as with one SSD, and that is enough for me. – umpirsky Aug 21 '14 at 10:10
  • @tomodachi Actually, it is not the same, but I am aware of the risk. Thanks. – umpirsky Aug 21 '14 at 10:11

The BIOS boot partition(s) must be created on the disk(s) not the RAID device.

One BIOS boot partition is enough for you as your system won't boot with one disk only.

Linux soft RAID works on partitions, not drives. So you'll have to create one partition for the BIOS boot and one for the RAID.

You could have to create a third partition. /boot can be on RAID 1, can't be on RAID 5, and I'm not sure about RAID 0 but it probably can't.

  • So, I create BIOS boot partition on one drive, and then create RAID. Wont RAID creation destroy BIOS boot partition? – umpirsky Oct 6 '14 at 15:15
  • Linux soft RAID works on partitions, not drives. So you create 2 partitions on each drive, 1 for the BIOS boot and one for the RAID. – Sacha K Oct 6 '14 at 16:18
  • Hehum, strange in i.stack.imgur.com/ABkvs.png you select devices, not partitions when creating RAID. – umpirsky Oct 7 '14 at 13:32
  • Either you missed it or it's a limitation of the interface. Linux soft RAID can work with partitions, and in your case it must be partitions. See raid.wiki.kernel.org/index.php/RAID_setup – Sacha K Oct 7 '14 at 13:49
  • Yes, you are right, mdadm create accepts partitions as parameters. Not sure how this GUI works behind the scenes, but you pick devices in it. :) – umpirsky Oct 7 '14 at 14:15

Did you try Lubuntu installer which still provide alternate ISO image to properly setup RAID ?

http://cdimages.ubuntu.com/lubuntu/releases/14.04.1/release/lubuntu-14.04.1-alternate-amd64.iso

I guess you already wiped all Windows related partitions to start clean right ?

  • Yes, I wiped Windows. What is this alternate ISO? How did you find it? Thanks. – umpirsky Oct 21 '14 at 10:04
  • Lubuntu is a Ubuntu-based ditribution and its maintainer is still providing alternate ISO image that are not provided anymore for the main Ubuntu release since 12.04 release. I figured it out while trying to setup Linux on my Asus UX51VZ with fakeraid. More info on my blog here : ux51vz.blogspot.ca – kochouloo Oct 22 '14 at 15:13
  • OK, my question is what are alternate ISO images? What is the difference between regular and alternate? How does that helps setting RAID. And what is the blog post you are referring to? Thanks. – umpirsky Oct 22 '14 at 20:47
  • Check this link : cdimage.ubuntu.com/lubuntu/releases/14.04.1/release which says : The alternate install image allows you to perform certain specialist installations of Lubuntu. It provides for the following situations: - setting up automated deployments; - upgrading from older installations without network access; - LVM and/or RAID partitioning; - installs on systems with less than about 384MiB of RAM (although note that low-memory systems may not be able to run a full desktop environment reasonably). – kochouloo Oct 23 '14 at 21:31
  • Oh, great. Thanks. Will try soon. – umpirsky Oct 24 '14 at 7:46
up vote 0 down vote accepted

Finally managed to install Ubuntu on RAID 0 and UEFI/GPT system, steps below:

sudo -s
apt-get -y install mdadm
apt-get -y install grub-efi-amd64
sgdisk -z /dev/sda
sgdisk -z /dev/sdb
sgdisk -n 1:0:+100M -t 1:ef00 -c 1:"EFI System" /dev/sda
sgdisk -n 2:0:+8G -t 2:fd00 -c 2:"Linux RAID" /dev/sda
sgdisk -n 3:0:0 -t 3:fd00 -c 3:"Linux RAID" /dev/sda
sgdisk /dev/sda -R /dev/sdb -G
mkfs.fat -F 32 /dev/sda1
mkdir /tmp/sda1
mount /dev/sda1 /tmp/sda1
mkdir /tmp/sda1/EFI
umount /dev/sda1

mdadm --create /dev/md0 --level=0 --raid-disks=2 /dev/sd[ab]2
mdadm --create /dev/md1 --level=0 --raid-disks=2 /dev/sd[ab]3

sgdisk -z /dev/md0
sgdisk -z /dev/md1
sgdisk -N 1 -t 1:8200 -c 1:"Linux swap" /dev/md0
sgdisk -N 1 -t 1:8300 -c 1:"Linux filesystem" /dev/md1

ubiquity -b

mount /dev/md1p1 /mnt
mount -o bind /dev /mnt/dev
mount -o bind /dev/pts /mnt/dev/pts
mount -o bind /sys /mnt/sys
mount -o bind /proc /mnt/proc
cat /etc/resolv.conf >> /mnt/etc/resolv.conf
chroot /mnt

nano /etc/grub.d/10_linux
# change quick_boot and quiet_boot to 0

apt-get install -y grub-efi-amd64
apt-get install -y mdadm

nano /etc/mdadm/mdadm.conf 
# remove metadata and name

update-grub

mount /dev/sda1 /boot/efi
grub-install --boot-directory=/boot --bootloader-id=Ubuntu --target=x86_64-efi --efi-directory=/boot/efi --recheck
update-grub
umount /dev/sda1

dd if=/dev/sda1 of=/dev/sdb1

efibootmgr -c -g -d /dev/sdb -p 1 -L "Ubuntu #2" -l '\EFI\Ubuntu\grubx64.efi'

exit # from chroot
exit # from sudo -s
reboot

Credits:

  • I think the step where you make /dev/sdb1 bootable is unnecessary. Since you set up the drives as raid0, if either of the drives fail, the raid unit does not work, so being able to boot from /dev/sdb1 if /dev/sda1 is broke probably does not help you. However, it probably does not hurt, either... – Niclas Börlin Jun 3 '16 at 18:38

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.