11

I am using Ubuntu GNOME 14.04. I integrated my Google account with it. But every time I login GNOME asks for my google account password. But when I give it, it simply wont accept it! I am 100% sure I am typing the right password for my google account(It doesn't have 2 step verification at present. I was using it before but not now.) Since it didn't work I tried my login password but that too didn't work. Then I removed integration for that account from "Online Accounts" then removed all my cache and tried integrating again. It integrates, but again, if I type in my password when asked for, the same issue persists. Here is a screen shot:

(asking for password:)

enter image description here


(after right password is given:)

enter image description here

I tried following this answer partly(I deleted goa-1.0 but not evolution since it would delete my evolution configuration which I want!) But deleting goa-1.0 didn't let me integrate my google account at all and so it doesn't work!(I recreated goa-1.0 and now I can reintegrate my account but the password issue persists).

So now my question is: How do I integrate my google account with my Ubuntu GNOME without any such issues as explained above?

PS:- Should I be doing something with seahorse here? I dunno how it works and all and so if I have to use it, tell me what to do elaborately.

  • No. As I say above "It doesn't have 2 step verification at present. I was using it before but not now." – VenkiPhy6 Aug 2 '14 at 12:16
  • okay..will try.. – VenkiPhy6 Aug 2 '14 at 12:18
  • Doesn't seem to work! So I integrated, it asked for the password and I gave my app specific password..but..it wont accept!!! That's weird ! – VenkiPhy6 Aug 2 '14 at 12:27
  • Is this a bug??!! – VenkiPhy6 Aug 2 '14 at 12:29
  • 3
    So I tried something...I disintegrated my google account from GNOME. Then went to 'evolution' and connected 'evolution' to my google account and it works fine! Evolution(like GNOME) asked for my password, I gave it my password and it doesn't ask it any more! Works like a dream! So this is clearly a problem with the account integration in GNOME. – VenkiPhy6 Aug 2 '14 at 12:48
1

It's a known bug: #1353951.
It will be fixed with the last version of evolution-data-server (still in 'proposed').

1

From Google's help:

Google may block sign-in attempts from some apps or devices that do not use modern security standards. Since these apps and devices are easier to break into, blocking them helps keep your account safe.

Some examples of apps that do not support the latest security standards include:

  • The Mail app on your iPhone or iPad with iOS 6 or below
  • The Mail app on your Windows phone preceding the 8.1 release
  • Some Desktop mail clients like Microsoft Outlook and Mozilla Thunderbird

You have two options:

  • Option 1: Upgrade to a more secure app that uses the most up to date security measures. All Google products, like Gmail, use the latest security measures.
  • Option 2: Change your settings to allow less secure apps to access your account. We don't recommend this option because it might make it easier for someone to break into your account. If you want to allow access anyway, follow these steps:
    • Go to the "Less secure apps" section in My Account.
    • Next to "Access for less secure apps," select Turn on. (Note to Google Apps users: This setting is hidden if your administrator has locked less secure app account access.)
0

I have exactly the same problem. I tried to integrate my google calendar into Gnome calendar, but setting up google online accounts caused the problem described here. - I had to remove google online account from Gnome - Set up Evolution to use my google account including google calendar Problem solved. G

0

This seems to be a known issue with GNOME accounts integration feature. To solve this issue, for the time being, one might use evolution instead of integrating one's account with GNOME.

0

I had the same issue in Ubuntu 14.04. I thought that I had corrected it by deleting the failing account and reinstalling the account information. However, the problem came back.

So I looked harder and found that somehow an account setting had changed (damn gremlins!).

Here's a check.

If your system starts prompting for a password and won't accept the one you enter, edit the settings for the account that is failing (edit->preferences->edit).

Under Receiving Email, check the Authentication pull-down. If it says Password, that's the problem because Password is not a valid selection.

Click Check for Supported Types and select the one that does not have a line through it.

Restart Evolution and check it out.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.