I recently bought a D-Link router and configured it.

From my Android, the access point is providing full internet access. My Ubuntu laptop gets internet access from other access points.

The problem is I cannot get internet access with just my router (I also had tried connecting to a router some time back and had this same problem, but I switched to ethernet then).

I can connect to the network, but if I try pinging the router I get a Destination Host Unreachable error.

I cannot discover my router with nmap either. nmap just gives my own computer (not even the Android device).

Ethernet connection to my router works perfectly fine.

Here are the configurations:

prakhar@aS4v4g3wOrld:~$ sudo iwconfig wlan0
wlan0     IEEE 802.11abg  ESSID:"aRM4g3ddOn-2.4GHz"  
          Mode:Managed  Frequency:2.437 GHz  Access Point: C4:A8:1D:8C:99:AC   
          Bit Rate=52 Mb/s   Tx-Power=200 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=70/70  Signal level=-25 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

prakhar@aS4v4g3wOrld:~$ cat /etc/network/interfaces
# interfaces(5) file used by ifup(8) and ifdown(8)
auto lo
iface lo inet loopback

auto wlan0
iface wlan0 inet loopback

prakhar@aS4v4g3wOrld:~$ sudo lshw -C network
       description: Wireless interface
       product: BCM4313 802.11bgn Wireless Network Adapter
       vendor: Broadcom Corporation
       physical id: 0
       bus info: pci@0000:0a:00.0
       logical name: wlan0
       version: 01
       serial: <removed>
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=wl0 driverversion= (r415941) ip= latency=0 multicast=yes wireless=IEEE 802.11abg
       resources: irq:19 memory:d4500000-d4503fff
       description: Ethernet interface
       product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:0b:00.0
       logical name: eth0
       version: 07
       serial: <removed>
       size: 1Gbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full firmware=rtl8168e-3_0.0.4 03/27/12 latency=0 link=yes multicast=yes port=MII speed=1Gbit/s
       resources: irq:43 ioport:2000(size=256) memory:d4404000-d4404fff memory:d4400000-d4403fff

prakhar@aS4v4g3wOrld:~$ sudo ifconfig -a
eth0      Link encap:Ethernet  HWaddr a0:b3:cc:46:93:05  
          inet addr:  Bcast:  Mask:
          inet6 addr: fe80::a2b3:ccff:fe46:9305/64 Scope:Link
          RX packets:3207 errors:0 dropped:0 overruns:0 frame:0
          TX packets:4052 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:1858395 (1.8 MB)  TX bytes:662320 (662.3 KB)

lo        Link encap:Local Loopback  
          inet addr:  Mask:
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:6960 errors:0 dropped:0 overruns:0 frame:0
          TX packets:6960 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:594878 (594.8 KB)  TX bytes:594878 (594.8 KB)

wlan0     Link encap:Ethernet  HWaddr 84:4b:f5:aa:01:bf  
          inet addr:  Bcast:  Mask:
          inet6 addr: fe80::864b:f5ff:feaa:1bf/64 Scope:Link
          RX packets:68 errors:0 dropped:0 overruns:0 frame:9105
          TX packets:325 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:10677 (10.6 KB)  TX bytes:38468 (38.4 KB)

Detailed info is here.

I have run out of ideas. Any help?

EDIT: So I logged on to Windows 8.1 and still the same: connected but no internet.

I went to the HP website (I own a dv6) and downloaded this. It's Broadcom driver version, released in 2012! And voila it works. Sometimes I envy Windows support.

So I dug deeper and found this launchpad bug. It was confirmed in May 2014 and still no resolution :(.

I have tried broadcom-sta, brcmac, wl, even the proprietary driver listed in Additional Sources (it's STA I think). Nothing works.

Does anybody have a clue?

EDIT: Solved. Here's the new driver + configuration in case anyone else needs it.

  • Please add the output of ifconfig to your question. – Jos Aug 2 '14 at 11:45
  • Please run the following command to help us troubleshoot the issue: cd ~/ && wget -N -t 5 -T 10 dl.dropbox.com/u/57264241/wireless_script && \ chmod +x wireless_script && \ ./wireless_script It will download a script and create a file named wireless-info.txt or wireless-info.tar.gz in your home folder with wireless information so we can see the condition of your wireless at the time. The MAC address, WPA key and WEP key are removed for your security. Paste contents of the wireless-info.txt or wireless-info.tar.gz file at pastebin.ubuntu.com or alternatively pastebin.com t – mchid Aug 2 '14 at 11:58
  • I was initially on that. Doesn't work. I added more information to OP. Can you brainstorm a bit more? – ps95 Aug 2 '14 at 17:21
  • @prakharsingh95 please run the scrypt please to help us with this issue. thanks! – mchid Aug 2 '14 at 18:28
  • http://paste.ubuntu.com/7935562/. Thanks! – ps95 Aug 2 '14 at 18:39

Please do:

sudo apt-get purge bcmwl-kernel-source

sudo -i
echo "blacklist b43" >>  /etc/modprobe.d/blacklist.conf
echo "blacklist ssb" >>  /etc/modprobe.d/blacklist.conf


  • Hi, your method did work for me but now I am experiencing a slightly different issue. If I purge bcmwl and reboot, it works perfectly. But when I reboot, it shows this issue. It connects, link speed struggles, deops to 1mbps and then disconnect. Cannot connect anymore to the AP. I have noticed that when it's working b43 and brcsmac are loaded, but when it's not, it's just brcsmac. Any ideas? – ps95 Sep 6 '14 at 7:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.