2

Today I got an update to Skype 4.3. I was really happy to see that and I immediately update it from 4.2 through software update program (default in Ubuntu). After the update I tried to start Skype but after few seconds nothing happend. So I opened up terminal and typed command skype and I found the problem. There it is:

Skype problem with Gtk

user@hostname:~$ skype
Gtk-Message: Failed to load module "overlay-scrollbar"
Gtk-Message: Failed to load module "unity-gtk-module"
Gtk-Message: Failed to load module "canberra-gtk-module"
Aborted

I already tried to find unmet dependencies, but it seems that there is everything installed. I'm using Ubuntu 14.04.1 64-bit. How to solve that problem?

  • Well I get the first error because I unintalled overlay-scrollbar have you tried to --reinstall that? – Tim Aug 2 '14 at 10:18
  • I tried and problem still exists. – user1257255 Aug 2 '14 at 11:00
  • Tried for all 3? – Tim Aug 2 '14 at 11:18
  • No, just for overlay-scrollbar, because I don't know in which package are unity and canberra gtk modules. If I try to reinstall them I got error E: Unable to locate package unity-gtk-module. – user1257255 Aug 2 '14 at 12:39
  • i expect it is in ubuntu-desktop – Tim Aug 2 '14 at 12:39
1
sudo apt-get install libcanberra-gtk-module 

or possibly, force the i386 version:

sudo apt-get install libcanberra-gtk-module:i386

I am uncertain of the dependencies and requirements for the other two: my understanding is that "overlay-scrollbar" is not critical, but unity-gtk might be.

sudo apt-get install unity-gtk2-module:i386

I am facing a similar issue.

  • I discovered those two packages a little bit before I saw your reply. They are a part of fix, but there's a new problem. You have to install overlay-scrollbar-gtk2:i386, but it is not possible due to unmet dependencies which are already installed. And there's another message which is saying something about GLib and GSettings backend. I know that much for now... – user1257255 Aug 2 '14 at 17:01
  • It seems that there's the end of Skype usage for users which have the same problem as us. I successfully installed all dependencies and after when I run skype command, there's just message: Aborted. I don't know what could be wrong -.-". – user1257255 Aug 2 '14 at 17:18
  • LOL! Check out the last comment in reply of ShadowMitia. It works even if you don't have dependencies mentioned in main post. – user1257255 Aug 2 '14 at 17:20
0

You should try reinsatlling the skype package if you haven't already. If it still doesn't work maybe you should try to download and install from the skype official website?

  • 1
    I reinstalled Skype package and there wasn't any change. I will not install Skype from official website, because we need to find out what's the problem with the version from Ubuntu repository and fix it, to enable new users good experience and solve my problem :) – user1257255 Aug 2 '14 at 15:38
  • 1
    That seems fair enough! I seem to remember I had a problem while upgrading skype a few months ago, I remember solving it by doing mv .skype skype-bak, I never understood why but I only wanted it to work ;) – ShadowMitia Aug 2 '14 at 16:49
0

Well there's something else: see this thread from the Skype support forums. http://community.skype.com/t5/Linux/Skype-4-3-crash-on-ubuntu-14-04/td-p/3219892

Even with these dependencies unmet, it seems that clearing the files download history does the trick. It did for me, and I am now able to use Skype 4.3 on Ubuntu 14.04

You can try this (untested)

$ sqlite3 ~/.Skype/[username]/main.db
> UPDATE Messages SET body_xml=substr(body_xml,instr(body_xml,'<files')) WHERE type=68 AND body_xml LIKE 'posted%';
> .quit

Or simply delete ~/.Skype (the Skype directory under your home folder). Then try starting up Skype, and see how it goes.

0

I had the same error. I had to

sudo apt-get --purge remove skype

and for some strange reason also

sudo apt-get --purge remove skype-bin

then remove the hidden folders .Skype and .config/skype in my home directory. Download the new "skypeforlinux" from the official website, select "skype for linux DEB". Install the new skype by navigating to the Download folder and doing

sudo dpkg -i skypeforlinux-64.deb
  • Didn't work for me – Camilo Rada Feb 14 '18 at 1:57
  • 1
    Yeah it doesn't work with the most recent version of skype anymore. You might want to go to the skype website and look for older versions. skypeforlinux_8.10.0.4_amd64.deb is the one that I downloaded. It runs fine on Ubuntu 14.04 – mcExchange Feb 14 '18 at 9:46

protected by Community Mar 5 '16 at 19:04

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.