1

To flow into the problems I had been dealing with, my copy of Lubuntu 13 became so unstable that I decided to do a fresh install of the alternative install of Lubuntu 14. Had quite a bit of trouble with that, but eventually, after some hours, got it through using a terminal command to make a bootable USB.

However, a particular problem that affected my prior system seems to have followed me here, and in researching/contemplating it, I think it was the problem that made my prior system so unstable.

Everytime I boot, I get this message that "cryptswap1" is not mounted, along with a prompt to manually fix it and whatnot. I don't think much of it, but in reading on it, I see it's connected to RAM-saps, and my constantly having to reboot prior was definitely due to constant computer freeze-ups. Thus, I suspect my not getting this cryptswap1 business in order is why my computer was so malfunctional.

I did search these forums and WAS following along in this guide:

https://askubuntu.com/a/342002/217795

But I got stuck on the Gparted portion. I managed to install and run GParted, but when I request that its turn /dev/sda5 into linux-swap, it cannot do so, and the source of the error is confusing. Otherwise the file system is listed as "unknown" for the partition.

I tried double-checking my terminal commands -- a funny thing about writing here is that it prompts all sorts of thoughts for what to research or solutions to try -- and I may have goofed up there.

In step two, it says to "save the file", but how does one do that within the terminal? I cannot find any save command, and there's no respond to ctrl + s.

Also, I'm having a tough time comprehending the way the terminal commands function, as, in being such a newb, I can presently only think in concrete-bound matters, and just copy the steps concretely, unable to apply originally. Thus, when asked to input sudo nano -w /etc/crypttab , I can follow through, but when it tells me to open /etc/fstab I get confused when sudo -w /etc/fstab doesn't give me the same results.

So I either goofed in doing the proper modifcations in terminal, or else I've got to get myself unstuck in Gparted somehow.

So what should this foolish man do to get his RAM back?


Oops. I forgot to include the error-info from GParted. It doesn't seem to have any useful information, but in case anyone asks for it:

GParted 0.18.0 --enable-libparted-dmraid --enable-online-resize

Libparted 2.3 Format /dev/sda5 as linux-swap 00:00:01 ( ERROR )

calibrate /dev/sda5 00:00:00 ( SUCCESS )

path: /dev/sda5 start: 501760 end: 156301311 size: 155799552 (74.29 GiB) clear old file system signatures in /dev/sda5 00:00:00 ( SUCCESS )

write 68.00 KiB of zeros at byte offset 0 00:00:00 ( SUCCESS ) write 4.00 KiB of zeros at byte offset 67108864 00:00:00 ( SUCCESS ) write 4.00 KiB of zeros at byte offset 79769366528 00:00:00 ( SUCCESS ) flush operating system cache of /dev/sda 00:00:00 ( SUCCESS ) set partition type on /dev/sda5 00:00:01 ( SUCCESS )

new partition type: linux-swap(v1) create new linux-swap file system 00:00:00 ( ERROR )

mkswap -L "" /dev/sda5

/dev/sda5: Device or resource busy


Update: Problem Resolved

I'm sorry that I forgot to give a definitive finish to this problem. Anyhow, I fresh installed the latest Lubuntu, and aside from getting rid of cryptswap1, I think Google Chrome was the major problem. My old laptop is really underpowered, and apparently they gave a major update to Chrome that made it "crash-proof." Unfortunately, that crash-proof status made it a MAJOR resource hog, so I rely on Firefox now and everything runs well.

1 Answer 1

1

First of all, you are using Lubuntu instead of Ubuntu, so you do not have nano installed in your machine. You should use leafpad. The best way to open a text file as root is to type:

gksudo leafpad the_file_adress.

Second, Lubuntu 14.04 should not be using a swap partition. It must have got one, but its priority should be set as -1 and a zram "device" ought to be used instead, most of times. You can check if this is happening by writing this in a shell:

cat /proc/swaps

Zram is a software which creates a tmpfs (temporary file system which is a file system in RAM) where it stored the data compressed to avoid using a swap partition.

About the problem, I do not know if you need an encrypted swap partition since it ought not to be used. Can I ask you how much RAM your computer has? Did you chose to encrypt your home folder when you were installing Lubuntu? If you did it, the encrypted swap partition may be compulsory. I do not know the matter.

Perhaps, the best choice is to follow that user's instructions. I think you can use the disk utility of Lubuntu instead of GParted, but be careful. And you ought to change the seventh step so as to set the priority of that swap partition as -1. You can run sudo swapon -p -1 /dev/..., where ... is the same as previously in their instructions, instead of sudo swapon /dev/.... /dev/... must be the swap device.

However, I have not been able to found out if writing the minus sign in this way is allowed. Perhaps, some user with more knoledge of linux might confirm it. Otherwise, you can try typing it.

If you did not chose to encrypt anything when you were installing, you'd better not run sudo ecryptfs-setup-swap.

I should tell you that more experienced users of Lubuntu usually follow its mailing list: https://lists.ubuntu.com/mailman/listinfo/lubuntu-users. Writing an email there is the best support option.

Good luck.

2
  • Thanks. I ended up resolving it by some other means. Apparently I goofed up the boot by what I had done in terminal, so I had to fresh install the system all over again. This time I opted not to have encryption, and the cryptswap1 problem didn't appear. It's much more stable now, though I also figured out that installing flash and ad blocks aided my CPU and RAM even more, as internet browsing was where most of the freezeups were occurring. My hand-me-down laptop must be particularly old: It has slightly less than 500MB, and the processor frequently maxes out according to task manager.
    – Benjamin
    Aug 4, 2014 at 17:20
  • Lubuntu's said to be able to run well with even less RAM, though there're people who disagree about the threshold. The CPU of my computer is a Pentium IV and watching online videos with a navigator is what maxes it out. It can't run them at 480p. I get a much better performance with VLC player (in Lubuntu software center). I copy the link of the video and open it with VLC, which works for YouTube. It runs them at 720p with no problem. However, my computer is not a laptop and it has more RAM. I suppose zRam may use more CPU time to compress and uncompress data when there's little RAM available. Aug 5, 2014 at 10:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.