After I restarted my computer to finish a upgrade, I could not log in at Skype anymore.

It only shows the message:

Skype can't connect.

If I try web version it works. I'm using Skype 4.2.

  • Try again, Skype is working now. – Alf Aug 1 '14 at 19:52
  • I just tried, the problem remains. – Jirico Aug 1 '14 at 19:58
  • 3
    The post about 4.2 being retired is probably the most correct. However, I'm on and for whatever reason, it still works. – Alf Aug 1 '14 at 20:04
  • possible duplicate of How to install Skype 4.3? – Eliah Kagan Aug 28 '14 at 19:12

According to this post, skype versions older than 4.3 are unable to connect as of today (2014-08-01). Though it could have just been a temporary outage of the skype servers, I was able to connect after updating skype.

| improve this answer | |
  • 8
    I just updated to 4.3 following this link: askubuntu.com/questions/488053/how-to-install-skype-4-3 and it worked! Thanks! – Jirico Aug 1 '14 at 20:13
  • 18
    Typical Microsoft. – Seth Aug 1 '14 at 22:25
  • 1
    This link explains the instructions for installing Skype 4.3 on a lot of distros including Ubuntu 12.04 till 14.04 for both 32bit and 64 bit systems. – Abhinav Aug 2 '14 at 16:24
  • Skype isn't updated since for Linux, Thanks Microsoft. – danger89 Aug 28 '15 at 16:22

First get rid of the old skype from repo:

sudo apt-get purge skype

Second, delete your ~/.Skype folder

rm -R ~/.Skype

Then download skype-ubuntu-precise_4.3.0.37-1_i386.deb from http://www.skype.com/en/download-skype/skype-for-linux/?intcmp=blogs--generic-click--skype-4-3-for-linux and execute it as a deb package:

sudo dpkg -i skype-ubuntu-precise_4.3.0.37-1_i386.deb
| improve this answer | |
  • 1
    This worked perfectly for me. – Pippin Aug 19 '14 at 19:27
  • a sudo apt-get -f install may be required if your system a bit broken like mine did. i blame this i386 architecture thingie. – hwjp Aug 27 '14 at 12:39
  • at the end you can see that Purge Anarchy is usefull – ucefkh Sep 17 '14 at 6:43

I had the same problem and the problem is that Skype 4.2 is no longer available. The solution is to install a fresh version of Skype 4.3 which is already available for users.

Here is what to do :

Step 1: Remove the old version of Skype (4.2 or older)

cd ~ && rm -r .Skype    
sudo apt-get remove skype skype-bin:i386 skype:i386
sudo apt-get install sni-qt:i386

Step 2: Install Skype version 4.3

For 32-bit Operating Systems: follow these steps

sudo apt-get update
sudo apt-get install gdebi
wget download.skype.com/linux/skype-ubuntu-precise_4.3.0.37-1_i386.deb
sudo gdebi skype-ubuntu-precise_4.3.0.37-1_i386.deb

For 64-bit Operating Systems: follow these steps

sudo dpkg --add-architecture i386
sudo apt-get update
sudo apt-get install gdebi
wget download.skype.com/linux/skype-ubuntu-precise_4.3.0.37-1_i386.deb
sudo gdebi skype-ubuntu-precise_4.3.0.37-1_i386.deb

That's it. Happy Skyping :-)

| improve this answer | |

I found a solution, worked in my Ubuntu 14.04, Just:

  1. Open “Software & Updates” and enable Canonical partners repository under Other Software tab.
  2. In the terminal do: sudo apt-get update; sudo apt-get install skype

here the Source!

Have a Grate day!

| improve this answer | |

There is an easy workaround if you need to use Skype older than 4.3:

1- Install Skype, launch it, tick the "log me in automatically" box and log in. Exit (and end the process if still active)

2- Download Skype deb package from https://launchpad.net/skype. Don't install it but extract the "Skype" binary file under /usr/bin

3- replace the /usr/bin/skype file with the version (you'll need root privileges)

4- start skype and it will log in automatically

Hope this solution will last because some webcams or products (Asus SV1T for examples) are only compatible with old versions of Skype!

| improve this answer | |

It is not your machine problem. Skype servers are down. This is not country specific.

I would like to add an official report, but Skype support is horrible.

UPDATE: it seems that Skype decided to shutdown the sopport for old versions (lower than 4.2). Update your client to be able use it.

| improve this answer | |

I was unable to call and receive calls from people using skype 4.3 for linux: the message error was Unable to connect

Removed skype installed from repository

sudo apt-get purge skype

and installed skype beta


sudo dpkg -i skypeforlinux-64.deb

Tested in Ubuntu 16.04 and 17.04

| improve this answer | |
  • skype no longer supports 4.3. – ravery Sep 29 '17 at 8:59

actually(and I discovered this quite randomly) the icon atop the desktop, displays the skype icon....which turns out to be the problem. I kept getting the same error message as you guys were getting, even after installing the latest version of Skype(4.3) But I had forgotten to quit Skype using that icon up there! After doing that, Skype performed flawlessly once more! I hope this helps someone.

| improve this answer | |
  • incidentally, after performing that action, Skype no longer displays an icon up there as it did with version 4.2 (just so you know what to expect) Google for a way to put the icon back up there, as 4.3 comes from Skype and not from our repositories. Another afternoon wasted(I wasn't doing anything anyway, right?) – Thomas Byers Aug 1 '14 at 22:42
  • As regards the icon, it works just as with 4.2, i.e. it needs the package sni-qt:i386. That package should have been installed automatically, unless you intentionally asked to not install recommended packages. – Gunnar Hjalmarsson Aug 2 '14 at 1:15
  • yes, thank you Gunnar, although I did have to add the dconf-editor to my apps and get it going from there. No, wait, I had to get a copy of sni-qt:i386 as the update does not come from our repositories, but from Skype. I understand why you would have thought it was coming automatically, however – Thomas Byers Aug 3 '14 at 2:24
  • I still think so since the latest package from the Skype web site includes (almost) the same "Depends" and "Recommends" lists as the package from Canonical Partner. Both recommend sni-qt. – Gunnar Hjalmarsson Aug 3 '14 at 4:29

Just , run this :

sh skype1404

Obviously, Download script before :

    wget https://raw.githubusercontent.com/abdennour/miscs.sh/master/skype1404
    chmod u+x skype1404

NOTE : whatever HW plateform (32 or 64), it works و الحمد لله

| improve this answer | |
  • 1
    @ucefkh : Because they don't like the last word which is "و الحمد لله" which means "Praise be to ALLAH" . And it is so logic because Allah said in Coran :"وَإِذَا ذُكِرَ اللَّهُ وَحْدَهُ اشْمَأَزَّتْ قُلُوبُ الَّذِينَ لَا يُؤْمِنُونَ بِالْآخِرَةِ ۖ وَإِذَا ذُكِرَ الَّذِينَ مِن دُونِهِ إِذَا هُمْ يَسْتَبْشِرُونَ" ==> " And when Allah is mentioned alone, the hearts of those who do not believe in the Hereafter shrink with aversion, but when those [worshipped] other than Him are mentioned, immediately they rejoice." . – Abdennour TOUMI Sep 17 '14 at 7:19
  • 1
    @ucefkh : <FOLLOW>... anywhere, Anywhere, WE have a proverb in arabic said :" إذا أنت أكرمت الكريم ملكته وإن أنت أكرمت اللئيم تمردا ." ==> TRANSLATE =>"Be generous to a generous person and you'd win him, be generous to a mean person and he'd rebel on you." Therefore, Don't care to them – Abdennour TOUMI Sep 17 '14 at 7:20
  • 1
    :) الحمد لله ALl praise to Allah – ucefkh Sep 17 '14 at 13:11
  • 1
    خوك من تونس . مرحبا – Abdennour TOUMI Sep 17 '14 at 19:55
  • 1
    خوك من المغرب مرحبا – ucefkh Sep 17 '14 at 21:14

Not the answer you're looking for? Browse other questions tagged or ask your own question.