How well does Ubuntu 11.04 (Natty Narwhal) support the processors of Intel's architecture Sandy Bridge and their Intel HD Graphics? Are there any problems with running 11.04 on Sandy Bridge?

  • Do you mean with or without integrated graphics? Jun 25 '11 at 19:21
  • @Seppo Erviäla I mean with the integrated graphics.
    – N.N.
    Jun 25 '11 at 19:26
  • 1
    Related: askubuntu.com/questions/22237/… Jun 25 '11 at 19:36
  • What computer are you thinking of? Because all the hardware may not have the same support.
    – Alvar
    Jun 25 '11 at 20:59
  • true, if you are still looking for a model, but still if you find a model and install 11.04 and then realize that it doesn't work, what do you do then? :)
    – Alvar
    Jun 26 '11 at 10:19

Out of the box, Natty does have issues with the Sandy Bridge architecture as discussed here on Phoronix.

In summary, performance is not great - as compared against Windows 7. In terms of general Natty support - no real issues are reported.

Fedora 15 is using the latest Mesa development code. If you use this together with the latest kernel, Phoronix are reporting that Sandy Bridge (and similar recent variants) are on a par - or even exceed Windows 7.

Thus, if you want to experiment - try installing the latest Kernel from here together with the latest bleeding edge drivers from this PPA.

Otherwise, stick with the standard Natty - things will get better in 11.10.

  • I have now used a Sandy Bridge system (Intel Z68) and the integrated Intel HD graphics with the default 11.04 drivers for two weeks. In this time I've only had black screens and freezes two or three times. So it has worked better than I anticipated.
    – N.N.
    Jul 18 '11 at 10:08

I have a

Acer Aspire 7750Gn, Core i5-Sandybridge 2410m 2,3 GHz, 4GB, 120Gb SSD + 500GB HD, Ati 6650 1024MB, DVD-RW, 17,3 TFT, USB 3.0.

and not a single problem with Ubuntu.

Hibernate/suspend work. USB 3.0 works. And the SSD is a true monster. Display works flawlessly (with the recommended driver).

Even the overclocking/turbo boost works after fiddling with some software See also Is Turbo Boost Working?

Kernel 2.6.38 and higher work flawlessly for me.

  • 1
    I actually tested 2 sandy bridge models and both did not work very good on Ubuntu or any other for that matter. Sometimes they would go slow, crash, freeze, etc.. Jun 25 '11 at 19:24
  • 1
    Not a single problem :) 8 sec boot time :D
    – Rinzwind
    Jun 25 '11 at 19:26
  • 2
    @CYREX Did those systems use the integrated graphics?
    – N.N.
    Jun 25 '11 at 20:37
  • 1
    Most of the problems have been with the on-chip graphics as far as I can remember reading. @Rinzwind's laptop uses a discrete graphics card which bypasses these issues. @fossfreedom's answer is more relevant to your situation, @N.N. -- You'll want to upgrade both the kernel and mesa and track the changes as they release new kernels and mesa versions.
    – Oli
    Jun 25 '11 at 21:00
  • @N.N. - Yes they did actually. But only before installing on both the nvidia card that was bought for them. So it was like an hour of use without the pcie card using only the integrated ones. Jun 29 '11 at 15:40

According to Phoronix support is still lacking in stock version of 11.04 but apparently can be achieved by upgrading to newest kernel, mesa and intel drivers. Atleast Phoronix has run some interesting tests successfully.


I had the same problems with 11.10. Config: i3 2100T in shutte eXPC H67 8GB 60GB SSD after installation resolution on VGA only 1024 or 800/xxx.

Over HDMI or DVI On-chip GPU not named but it worked anyway also tt high res.. After all available updates even GPU named in system information and everything works like it should be.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.