3

I receive following error in terminal:

No suitable Java Virtual Machine could be found on your system.
The version of the JVM must be at least 1.5.
Please define INSTALL4J_JAVA_HOME to point to a suitable JVM.
You can also try to delete the JVM cache file

I'm using 14.04.

  • what was the command to which this error came – agha rehan abbas Aug 1 '14 at 17:05
  • Just a ./ xxxxx.sh file execution. – empedokles Aug 1 '14 at 17:59
2

Just install the latest version of Java by opening a Terminal (CTRL + ALT + T) and running

sudo apt-get install openjdk-7-jre
  • Unfortunately I now receive an error from my .sh installer: testing JVM in /usr ... Starting Installer ... Aug 01, 2014 7:59:02 PM java.util.prefs.FileSystemPreferences$1 run Information: Created user preferences directory. ago 01, 2014 7:59:32 PM java.util.prefs.FileSystemPreferences syncWorld Avvertenza: Couldn't flush system prefs: java.util.prefs.BackingStoreException: /etc/.java/.systemPrefs/com create failed. – empedokles Aug 1 '14 at 18:01
  • Try running the script with root privileges. Just add sudo in front of the ./ – jnuk Aug 1 '14 at 18:06
  • It seems it cannot create the folder /etc/.java/.systemPrefs/com. In order to do that you have to run the xxxx.sh command by running as a root. That would be "sudo ./<your_file>.sh" – orestis Aug 1 '14 at 18:07
  • I guess a restart did it. I could start it up, but can't open a file with the software. – empedokles Aug 1 '14 at 18:11

Not the answer you're looking for? Browse other questions tagged or ask your own question.