1

I'm using netbeans and have lamp installed.

Now I'm trying to test the PHP installation so I configured Netbeans to copy the files to the /var/www/html/TEST_01 folder so the file is in localhost/TEST_01/index.php

When i go there with the browser all i see is a blank page, if i inspect the page i can see this:

<?php

phpinfo();

?>

So my guess is the index.php file is being treated as a .html file. I already tried putting the file in other folders like /var/www/test/index.php without luck.

3
  • 2
    What method did you use to install LAMP? – kraxor Aug 1 '14 at 11:13
  • sudo apt-get install lamp-server^ – octohedron Aug 1 '14 at 15:30
  • @Algorista Rather than keeping the solution in your question, it would be best for you to post your own answer saying what you did (i.e., that you installed that particular package, plus any other relevant info if any). That will make it clearer for people searching that this is solved and what the solution was (and also prevent it from being closed and deleted based on the idea that the problem went away without a known solution). Thanks! – Eliah Kagan Aug 15 '14 at 11:11
3

Fixed it installing libapache2-mod-php5

3
  • Icomplete answer, add how to install libapache2-mod-php5 too. – Vicky Dev Apr 27 '16 at 9:50
  • 1
    Hi Vicky Dev, sudo apt-get install libapache2-mod-php5 should work – octohedron Apr 27 '16 at 13:54
  • what is in package? why it is working..thanks @Gazta – Prashant Tapase Feb 26 '17 at 17:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.