0

My Somikon webcam doesn't get noticed by Cheese, Skype or VLC.

lsusb gives me: Bus 003 Device 003: ID 0ac8:3420 Z-Star Microelectronics Corp. Venus USB2.0 Camera

Cheese just doesn't find it like Skype (no device found). VLC recognizes it as /dev/video0 but when I try to capture it, it throws me an error that he can't open it. When I go to the System Settings and look for Input Devices he shows the microphone of my webcam as microphone Venus USB2.0 Camera and I see the Input if I speak or make noise. So this should work.

The following from here didn't change anything.

unload the driver module: sudo modprobe -r uvcvideo Then reload with the correct parameter: sudo modprobe uvcvideo quirks=16

My goal is to use the Webcam to videochat with Skype.

If it helps, this is my webcam: http://www.pearl.de/a-PX8185-1341.shtml

I use fully updated Ubuntu 14.04.1 with 64bit.

0

Install the device drivers containing packages:

sudo apt-get install build-essential linux-headers-`uname -r` libsbigudrv2 libsbigudrv0
  • Cheese now says (translated from German): Encountered an Error during Playback of the VideoSignal of the webcam. VLC now recognizes /dev/video1 instead of video0, but throws the same error. There is no change for Skype. EDIT: After restart Cheese now works! Skype doesn't detect any Webcam.... started Cheese another time and now he says that he didn't find any device. VLC only recognizes video0 and throws said error. lol what a mess. – Saturiel Aug 1 '14 at 14:12
  • try with reinstalling the packages: skype and vlc – user308564 Aug 1 '14 at 14:24
  • I did. Nothing changed. Can't get the Webcam working (even in Cheese). Tried some more restarts etc. – Saturiel Aug 1 '14 at 14:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.