17

Can you "fix" chrome's close, minimize, maximize buttons so they are on the left, and use ubuntu's theme? I might actually use chrome then.

1
  • 1
    Select the option to Use GTK+ theme in the chrome settings. The 'Use system title bar and borders' setting hides the buttons when I go full screen on Ubuntu 18.04, so disable that. May 17, 2018 at 14:08

3 Answers 3

38

I believe there is an option to use "System title bars" under the settings on the "Hamburger Menu" on the upper-right hand corner in Chrome. Navigate to settings, the same screen where you would select for chrome to use the GTK+ theme, and the setting is in there.

As shown in this picture:

enter image description here

4
  • Which theme are you using? Nov 1, 2016 at 14:41
  • You can also tell Chromium to use the GTK theme instead of the classic one
    – vinid223
    Dec 13, 2017 at 1:55
  • Thanks, it helped. Feb 12, 2020 at 7:44
  • dont know why, but for me it helped just to disabling it
    – FantomX1
    Nov 12, 2020 at 23:49
8

The problem with @Jbuch14 answer is that it adds an extra bar on top of everything, so it's not a real solution. I dont want any extra bars, I just want Chrome's own buttons to be at right side. How to do it?

edit: Ok I figured it out! Instead of enabling "use system title bar...", you DISABLE it, and then run command

gconftool-2 --set /apps/metacity/general/button_layout --type string ":minimize,,maximize,close"

and voila! No double top bar, and buttons are Windows-style at right.

4
  • The problem reappeared in 15.10 using Chrome 49 on KDE and this fix does not help anymore. I suppose that windowing manager used for Chrome even it being a GTK app is not metacity but kwin. Is there any solution for this setup too? The buttons are shown however when the window is not maximized.
    – smihael
    Mar 15, 2016 at 16:04
  • For me, @juch14's solution worked just fine, I'm running 14.04 though Mar 24, 2016 at 9:42
  • 1
    it doesn't work for me ubuntu 16.10 , does it has to do with the theme I'm using a different one , other than the default .
    – Ahmed Eid
    Mar 18, 2017 at 2:18
  • This is working fine on ubuntu 22.04. Google Chrome and the PWAs installed using the browser no longer have the titlebar buttons missing.
    – Timmy Chan
    Jan 25, 2023 at 13:26
1

Chrome and Ubuntu (Unity) uses different setting for positioning the window controls. Though Chrome popups always uses the system bars.


For Chrome controls: using gconf-editor create/edit the key button_layout under /apps/metacity/general with value close,minimize,maximize:


For system controls: using dconf-editor create/edit the key button-layout under org.gnome.desktop.wm.preferences with value close,minimize,maximize:

Note: works from 12.04 until 13.10, since 14.04 you can't change window controls side as stated in this answer.


To use Ubuntu theme use the options under Appearance in Chrome settings as pointed by @Jbuch14. When using system bars you are subjected to the note above.

10
  • No need of all this. @Jbuch14's answer is the simplest tweak you can ever do. Aug 29, 2014 at 5:27
  • nope, not if we want the Chrome styling of the buttons, and not having an a bar which might be ugly.
    – sidney
    Apr 13, 2015 at 17:31
  • between, it does not work for me @Sançao, it only works for normal windows, not for chrome.
    – sidney
    Apr 13, 2015 at 17:34
  • @sidney in a quick search I find out there is issues in some versions, I provided additional info in the answer. I'm now using Ubuntu 14.04 and Chrome 41 and these settings make no effect Apr 14, 2015 at 11:24
  • Thanks for the answer @Sanção. However I do not think that this is quite right. I'm currently using Ubuntu 14.04 using the Mate Environment, a fork of Gnome 2. It should behave as the Gnome fallback. I can have the buttons to the left on any windows, but not on chrome. As stated in this screenshot: image.noelshack.com/fichiers/2015/16/…
    – sidney
    Apr 14, 2015 at 11:44

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .