2

Ubuntu 12.04.4 LTS. Firefox 27.0. apt-get install firefox says it is already the latest version. I know it is not true.

I have precise, precise-backports, precise-security and precise-updates on my sources.list (full contents here).

I performed (apparently successfuly) and apt-get update and still the result is the same. I was able to install a new pakage (guake) so apt is talking to the internet just fine.

apt-get upgrade says "0 packages updated, 0 new installed, 0 to be removed, 0 not-updated".

Result of apt-cache policy firefox:

firefox:
  Instalado: 27.0+build1-0ubuntu0.12.04.1
  Candidato: 27.0+build1-0ubuntu0.12.04.1
  Tabela de versão:
 *** 27.0+build1-0ubuntu0.12.04.1 0
        500 http://br.archive.ubuntu.com/ubuntu/ precise-updates/main amd64 Packages
        500 http://security.ubuntu.com/ubuntu/ precise-security/main amd64 Packages
        100 /var/lib/dpkg/status
     11.0+build1-0ubuntu4 0
        500 http://br.archive.ubuntu.com/ubuntu/ precise/main amd64 Packages
  • 1
    Not a great answer, but at the bottom of the package's page, it does have download links.. you can download the deb files and install those. Have you tried sudo apt-get upgrade – Wilf Jul 31 '14 at 15:35
  • @Wilf Yeah, I don't want to install the .deb because IIRC it won't provide package updating, that's what I want, not to update to this specific version, but always to the latest possible to this distro. – That Brazilian Guy Jul 31 '14 at 15:40
  • Also, I tried apt-get upgrade, didn't work. – That Brazilian Guy Jul 31 '14 at 15:41
  • @chaskes I don't know what pinning or holding is. This is not my computer and I don't know how to check it. – That Brazilian Guy Jul 31 '14 at 15:43
  • I can see now that's not the problem here from apt-cache policy – chaskes Jul 31 '14 at 15:46
2

There are two posibilities:

  1. Brazil mirror is way behind

    I can assure is not:

    ➜  ~  apt-cache policy firefox
    firefox:
      Installed: (none)
      Candidate: 31.0+build1-0ubuntu0.12.04.1
      Version table:
         31.0+build1-0ubuntu0.12.04.1 0
            500 http://br.archive.ubuntu.com/ubuntu/ precise-updates/main i386 Packages
    
  2. There's a proxy that isn't working properly.

In the second case, you may have to ask the network administrator to fix it, bypass the proxy (using https or disabling it totally), or changing to other mirror removing the br part of your mirror list.

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.