8

I am using Ubuntu GNOME 14.04.

The "disable touchpad while typing" setting in the system settings does not work.

Any permutation of the "syndaemon" command does not work.

It is really annoying, when I am typing all of a sudden the focus will be on a new window, or a large chunk of text will be gone, etc.

I am using a Dell Inspiron 14 5000 series laptop, no proprietary drivers being used.

I also tried installing Pointing Devices from the Software Center and disabling from there. Did not work either.

There's the answer to this question: Touchpad issue: jumping cursor while typing (Ubuntu 14.04), syndaemon don't help but I don't want to try recompiling drivers unless there is definitely no other solution. Also there's this: https://gist.github.com/silverhammermba/a231c8156ecaa63c86f1 but this also involves patching drivers (also not clear how to apply it).

How can I get this to work?

3

I know exactly what the problem is (at least in my case which seems identic). It's because you're missing librecord.so . The GNOME setting require this file because it use syndaemon with -R option. As far as I know, that file has been dropped and no longer shipped with xorg-server.

There are many hard way you can actually achive disable typing function. Here from the easiest :

Using syndaemon Directly

Just launch

    $ syndaemon -d

or with option you may like. See syndaemon -h.

Just remember, without -R switch.

Patch the GNOME settings daemon

  1. Download the source available at
  2. Apply the following patch : http://pastebin.com/1xHukxR0
  3. Compile or build the package.
  4. Install and Done!

NB : Sorry, I don't provide the exact step as I'm not Ubuntu user again.

Recompile xorg-server with XRECORD

Shortly, compile with --enable-record and possibly --disable-xtrap. Found here.

1

Go to your terminal and run

syndaemon -i 1 -K -R -d

If that doesn't work maybe your touchpad does not support this function. If it works, put this command in the Startup Applications so it is applied at boot. This is how I solved this problem on Yoga 2 Pro.

0

Create an empty document, add the following lines:

#!/bin/sh
synclient TouchpadOff=2

and save it as $HOME/bin/touchpad-settings.sh

create the bin directory

mkdir -p $HOME/bin

Go to your dash and open Startup Applications, click Add and enter in the Command field:

$HOME/bin/touchpad-settings.sh

Enter anything that helps you remind what this thing does in the Name and Comment fields. ;-)

Click "Save" then "Close"

Next time you log on, typing will be disabled, so just for now, open a terminal and type:

$HOME/bin/touchpad-settings.sh

to prevent you from having to log off/on again! ;-)

You can add any additional commands that annoy you about your touchpad into this file as well. E.g. mine has:

#!/bin/sh
#Disable Horizontal and vertical scroll
synclient VertEdgeScroll=0
synclient HorizEdgeScroll=0
#DisableWhileTyping
synclient TouchpadOff=2
#Disable tap
synclient TapButton1=0
synclient TapButton2=0

To see all the possibilities you can turn on/off, go to a terminal and type:

synclient -l

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.