0

I was trying to change some settings with the compizconfig settings manager but there was a conflict between some of the appearance options.

Unfortunately, now I can't see the Unity dash or the panel at the top. I can see my desktop and open files and folders from there, but after I open them there is no button for closing or minimizing them.

Also shortcuts like Ctrl+Alt+T don't work.

Can I do anything to bring my pc back to normal without reinstalling Ubuntu?

1

Sounds like your Compiz and/or Unity settings are screwed up.

Try the following. First of all, since you can't fire up a terminal when in X, switch to non-graphical mode:

  1. Hit Ctrl+Alt+F1. This will get you to the non-graphical mode.

  2. Login there with your username and password.

Now from here, we'll try to reset your faulty configuration.

Option 1: Reset Compiz configuration

To reset only the Compiz settings, execute the following commands:

DISPLAY=:0.0 dconf reset -f /org/compiz
rm -r ~/.compiz* ~/.config/compiz*

This should restore your Compiz settings to default.

Finally, restart X (i.e., the graphical mode):

sudo service lightdm restart

Option 2: Reset Unity configuration

If the above doesn't solve your problem, try yo completely reset your Unity configuration. From this answer, you can use the unity-tweak-tool for this. You'll have to install it first:

sudo apt-get install unity-tweak-tool

Then, execute the following command:

DISPLAY=:0.0 unity-tweak-tool --reset-unity

Finally, switch back to X by hitting Ctrl+Alt+F7.

dummy transparent line

Hopefully, one of these will fix it.

  • When I type the first command and I press enter an error occurs. error: Cannot autolaunch D-Bus without X11 $DISPLAY – the_painter Jul 31 '14 at 8:31
  • Ah yes, makes sense. I edited my post and fixed the command, it should now work. – Malte Skoruppa Jul 31 '14 at 9:46
  • I typed the commands as you said. Unfortunatelly, nothing changed. – the_painter Aug 1 '14 at 9:35
  • Hm. Ok, in this case maybe it isn't the Compiz configuration that's faulty, but something else with Unity. I edited my post once more - switch to non-graphical mode again, and try Option 2. – Malte Skoruppa Aug 1 '14 at 10:45
  • Thank you very much for your time. I'll try this later. If it doesn't work I will reinstall ubuntu. It's not so hard eventually. – the_painter Aug 1 '14 at 11:36
0

You likely disabled the Ubuntu Unity Plugin so just open ccsm again & re-enable it. (/usr/share/applications & d. click on CompizConfig Settings Manager > open Ubuntu Unity Plugin settings to re-enable.

If you had enabled Window Decoration plugin then unity would have been disabled.

Running those reset commands will not re-enable unity plugin.

  • Good point, though I was thinking that if shortcuts like Ctrl+Alt+T don't work, it must be more than just the Unity plugin. That shortcut has nothing to do with Unity. Something's messed up there. So rather than trying to fix the setup manually, I'd rather reset it to its original state. – Malte Skoruppa Aug 1 '14 at 13:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.