This has probably been asked millions of times already, but I'm struggling to update my Ubuntu system from LTS to LTS, now that the upgrade to 14.04.1 is out. My system keeps notifying me to upgrade to the latest release, claiming that

Your current Hardware Enablement Stack (HWE) is going out of support
on 2014-08-07.  After this date security updates for critical parts (kernel
and graphics stack) of your system will no longer be available.`

However, when I run sudo do-release-upgrade, Ubuntu says I have no updates available. In addition, changing the prompt parameter in /etc/update-manager/release-upgrades to prompt=normal instead of prompt=lts throws the following error:

Checking for a new Ubuntu release
404  Not Found [IP: 80]
Err Upgrade tool
404  Not Found [IP: 80]
Fetched 0 B in 0s (0 B/s)
WARNING:root:file 'quantal.tar.gz.gpg' missing
Failed to fetch
Fetching the upgrade failed. There may be a network problem.

This seems weird to me as Quantal isn't even the current release, so I don't know why the system would be looking for it.

People have suggested appending the -d flag to the do-release-upgrade command, but the documentation says that this will install the development version of 14.04 which I don't want.

Any help would be appreciated to get me around this roadblock.

  • Are there any quantal related lines in your /etc/apt/sources.list?
    – muru
    Jul 31, 2014 at 5:49
  • I'll have to check later. Good suggestion.
    – Noel Forte
    Jul 31, 2014 at 5:51
  • No, there aren't any quantal lines in my system...thanks though!
    – Noel Forte
    Aug 3, 2014 at 2:53
  • To clarify, -d installs the current version, no matter what that is. It's not the development version, but is less tested. It's for this reason that do-release-upgrade on LTS versions won't upgrade until .1 is released. Aug 11, 2014 at 1:03
  • But .1 has been released. It was on the 24th.
    – Noel Forte
    Aug 11, 2014 at 1:04

1 Answer 1


You have to reinstall the update manager. First, remove/purge it:

sudo apt-get purge update-manager-core update-notifier-common

Then have a look at the console output. If it tells you, that some directories could not be removed, delete them manually. In my case:

rm -rf /var/lib/update-manager
rm -rf /var/lib/update-notifier

If you are on 13.04 or later, you should also do this to clear cached update messages:

sudo rm /var/lib/ubuntu-release-upgrader/release-upgrade-available

Then update your sources:

sudo apt-get update

Reinstall the update manager:

sudo apt-get install update-manager-core update-notifier-common -y

Only if you are currently on an LTS and want to upgrade to latest LTS, make sure that in /etc/update-manager/release-upgrades you have set:


Otherwise (upgrading any version to a newer version) set:


Now dist-upgrade should work:

sudo apt-get dist-upgrade
  • Note that removing update-manager is liable to also remove network-manager and hose networking (preventing the subsequent steps from working, unless you are able to access the network another way). You have been warned. Nov 18, 2014 at 1:32
  • 1
    It turned out that I changed my sources.list and added stuff and basically newbed it out a few years ago. I followed this guide, twice. With current sources then checked that I had quantal, got the quantal sources, redid this whole thing and it has now done its business. Thanks! Then the upgrade failed, basically, i left 3rd party sources in the list. I just cleared it down to the original sources for the dist and, now finally... it works. Really great answer!!!!! +beers
    – Piotr Kula
    Jul 1, 2015 at 19:58
  • Didn't work, and now update-manager doesn't exist.
    – Kaitain
    Jan 10, 2016 at 3:34
  • bravo!!! excellent solution that worked well when others failed Apr 18, 2018 at 20:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.