I have successfully installed and used Minecraft on my XUbuntu OS, but for some reason none of the tutorials on how to use Minecraft Forge have worked for me. I take the Forge files and put them into Minecraft.jar using Archive Manager, but when I go to open Minecraft, literally nothing happens. Minecraft won't even open anymore. I have tried uninstalling and reinstalling both, but Minecraft stops working after I install Forge.

Does anyone have any ideas on how to get this working? Has anyone else got this working on XUbuntu 14.04?

Thank you for your answers.

  • How did you install Minecraft? Are you just using the .Jar? – Jbuch14 Jul 30 '14 at 19:14
  • I am just using the .jar file. When I said install, I meant that I added an icon to the Menu, and I placed the .jar in .minecraft. – Jeffrey Drake Jul 30 '14 at 19:15
  • try doing it the way I said in the answer, thats how ive always done in in XUbuntu, Mint XFCE and even Unity so it should work – Jbuch14 Jul 30 '14 at 19:23

I reccomend installing Minecraft through the Unofficial PPA.

sudo add-apt-repository ppa:minecraft-installer-peeps/minecraft-installer

sudo apt-get update && sudo apt-get install Minecraft-Installer

After installing the installer, login and install the version of Minecraft you wish to install. Then download the version of forge (preferably the universal installer) for the version you need. You will need to allow executing the file as a program. On XFCE do

chmod u+x forgeversion.jar

Then make sure you are set to run Forge with Java and not Archive manager. It should auto detect the install directory for Minecraft. Then simply launch Minecraft and select the version with Forge in the title. Hope this helps!

  • I keep getting the error message that "sudo: add-apt-repository: command not found" – Jeffrey Drake Jul 30 '14 at 19:38
  • I am literally opening Terminal Emulator and copy pasting exactly what you put in your answer, and I am getting the error: "sudo: add-apt-repository: command not found." – Jeffrey Drake Jul 30 '14 at 19:45
  • I assume its the XFCE terminal? I just ran the command and its working on my end. are you typing in the colon after sudo ? or is that just the output of the terminal – Jbuch14 Jul 30 '14 at 19:51
  • 1
    I got it to work. I downloaded Minecraft.jar from minecraft.net. I then placed it in a folder I had created in "Home" called ".minecraft". I added Minecraft to the XUbuntu Launcher by linking an icon to "/home/yourcomputername/.minecraft/". The command I used to execute was java -jar Minecraft.jar I ran Minecraft, logged in with my username and password, and downloaded Minecraft 1.7.10. Afterwards, I downloaded the latest version of the Forge INSTALLER. I then ran the installer after making the file executable with the terminal command: – Jeffrey Drake Jul 30 '14 at 20:09
  • 1
    'chmod u+x /home/yourcomputername/Downloads/forge-1.7.10-' I then ran the Forge installer using JDK 7, and it installed everything correctly. It's all in working order. Thank you Jbuch14 for all of you help! You were very patient. – Jeffrey Drake Jul 30 '14 at 20:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.