First of all, I think this question is not duplicated, because I have tried all other solutions I found here, but nothing solved my problem.

I use Ubuntu 14.04 64 bit.

I have tried until now: sudo apt-get install skype -> It didn't work. The error was:

The following packages have unmet dependencies:
skype : Depends: skype-bin
E: Unable to correct problems, you have held broken packages.

I have tried sudo dpkg add-architecture && sudo dpkg -i skype-ubuntu-precise_4.3.0.37-1_i386.deb but it didn't work too. The error was:

dpkg: dependency problems prevent configuration of skype:
skype depends on libqt4-dbus (>= 4:4.5.3); however:
Package libqt4-dbus is not installed.
skype depends on libqt4-network (>= 4:4.8.0); however:
Package libqt4-network:i386 is not installed.
skype depends on libqt4-xml (>= 4:4.5.3); however:
Package libqt4-xml:i386 is not installed.
skype depends on libqtcore4 (>= 4:4.7.0~beta1); however:
Package libqtcore4:i386 is not installed.
skype depends on libqtgui4 (>= 4:4.8.0); however:
Package libqtgui4:i386 is not installed.
skype depends on libqtwebkit4 (>= 2.2~2011week36); however:
skype depends on libstdc++6 (>= 4.2.1); however:
Package libstdc++6:i386 is not installed.
skype depends on libx11-6; however:
Package libx11-6:i386 is not installed.
skype depends on libxext6; however:
Package libxext6:i386 is not installed.
skype depends on libxss1; however:
Package libxss1:i386 is not installed.
skype depends on libxv1; however:
Package libxv1:i386 is not installed.
skype depends on
dpkg: error processing package skype (--install):
dependency problems - leaving unconfigured
Processing triggers for hicolor-icon-theme (0.13-1) ...
Processing triggers for gnome-menus (3.10.1-0ubuntu2) ...
Processing triggers for desktop-file-utils (0.22-1ubuntu1) ...
Processing triggers for bamfdaemon (0.5.1+14.04.20140409-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Processing triggers for mime-support (3.54ubuntu1) ...
Errors were encountered while processing:
skype

I have tried to use after sudo apt-get -f install but it didn't solve.

I have tried to install by using Gdebi. The error was:

Cannot install 'libqtwebkit4:i386'

I have tried to install using Ubuntu Software Center. The error was:

Cannot install 'libqtwebkit4:i386'

I have tried changing the server in "Softwares and Updates". I have tried to use "Main Server" and "Servers for United States". But it couldn't solve my problem.

Anyone has any idea how to solve that?

SOLVED

Well, I formatted my pc and I installed Skype first of all. Probably another installation that I had done before the Skype instalation was the problem, i guess.

Thanks people!

  • Try adding the Partner Repos and then try installing the Skype you downloaded again. Might help it find the skype-bin package. – amanthethy Jul 30 '14 at 19:44
  • Unfortunately my partner repos had been added already. – z_inx Jul 30 '14 at 20:07
  • 1
    I am facing the same issue (Elementary OS: Ubuntu 14.04) and have pretty much every way; but unfortunately I can't afford to format the PC to install Skype. Guess I'll rather try to convince the people on the other end use an alternative like Hangout. – amar Jun 26 '15 at 8:17
  • This question is not "solved" by a new installation of the complete OS. I have the same problem on 16.04. Something I try to install messed the multiarch up so it is now somehow trapped. It is not understandable for me why I am not able to simply purge anything not usefull and do a fresh install of skype then. – Ben Nov 22 '16 at 0:31
  • 3
    Possible duplicate of How to install Skype 4.3? – David Foerster Jul 5 '17 at 10:12

I'm running 14.04 64bit, here is how I installed.

Downloaded skype 4.3 from here, and I used Gdebi, to install it, and it installed fine. if you don't have Gdebi installed, just press Ctrl+Alt+T on your keyboard to open Terminal. When it opens, run the command(s) below:

sudo apt-get install gdebi

enter image description here

As I said, I haven't had any issuses using the method Stated above. Another thing that you can do to fix broken packages, you can do

sudo apt-get clean && sudo apt-get update
sudo apt-get upgrade

OR

Go to synaptic package manager if you have it installed, go to Edit --> Fix broken Packages.

An alternate way to install it, is

sudo dpkg --add-architecture i386
sudo apt-get update
wget -O skype-install.deb http://www.skype.com/go/getskype-linux-deb
sudo dpkg -i skype-install.deb

After this if you get any error like cannot install 'libqtwebkit4:i386' or some other package, try this command.

     sudo apt-get upgrade --fix-missing

It will suggest you to try the following command.

    sudo apt-get -f install

After executing the above command, try the following one once again.

sudo dpkg -i skype-install.deb

For more details, see the official Skype forum here.

Hope this will help you :)

  • As I said in my post, I have tried to use Gdebi, but I had the error: Cannot install 'libqtwebkit4:i386'. – z_inx Jul 30 '14 at 18:54
  • Thanks for trying to help, but unfortunately I have tried these other 2 ways to install, but both show me the same error: Cannot install 'libqtwebkit4:i386'. – z_inx Jul 30 '14 at 19:17
  • Install libqtwebkit4:i386 by launchpad didn't solve the problem, because, apparently, it has other dependencies. When I tried to install, I got the error "Cannot install 'libqt4-opengl:i386'". :( – z_inx Jul 30 '14 at 20:11
  • try the following steps! It worked on debian 7 , ubuntu 14.04 and ubuntu 14.10 1) dpkg -i skype-install.deb now you will get some list of errors 2) dpkg --add-architecture i386 3) sudo apt-get update 4) sudo apt-get -f install --fix-missing 5) dpkg -i skype-install.deb whoo! it works :-) – babu Jan 14 '15 at 5:24
  • 5
    Followed the provided steps; but still ending up with skype depends on libqtwebkit4 (>= 2.1.0~2011week13). – GhostCat Oct 9 '15 at 10:56

First run :

sudo apt-get install -f

to install the deps related with the OS 14.04LST 64 bit and then try below commands ... skype 4.3 installs perfectly

sudo dpkg --add-architecture i386
sudo apt-get update
wget -O skype-install.deb http://www.skype.com/go/getskype-linux-deb
sudo dpkg -i skype-install.deb

It worked for me .... ;;;; :)

Running the following commands :

sudo apt-get clean && sudo apt-get update
sudo apt-get upgrade

Resolved the issue for me.

Steps:

sudo sh -c "echo 'deb http://archive.canonical.com/ubuntu/ trusty partner' >> /etc/apt/sources.list.d/canonical_partner.list"
sudo apt-get update
sudo apt-get install skype
  • When I do this using trusty 14.04, I get E: Unable to locate package skype – henrywright Feb 6 '15 at 0:41

I have run into the same problem istalling Skype 4.3 on Ubuntu 13.10. However when following the instructions above, Skype 4.2 always ket showing up, even when removing skype before downloading the newer version. In order for it to work, I had to remove the .Skype configuration file in my home directory:

rm -r ~/.Skype

Don't worry, you will not loose your contacts or anything else. The only slightest annoyance that I can see that at first some of your contacts will show up with their skype name and not the familiar full name.

In my case I've got the same problem out of not following the RTFM principle :) Installed some packages from xorg-edgers and then haven't removed them properly as it is said in the installation comment (i.e. just removed the repository but not the installed packages). This caused a domino effect which lead apt to be unable to install any i386-library dependent packages...

I've found it by trying installing packages with aptitude which verbose directly the issues (different versions of 64-bit packages). Then I've added back the xorg-edgers repository and removed it properly with:

sudo apt-get install ppa-purge
sudo ppa-purge xorg-edgers

Hope it will help somebody...

I fixed this exact same problem by enabling "Recommended Updates (trusty updates)" in the "Software & Updates" control panel, "Updates" tab.

  • This is the perfect answer! – Flimm Dec 27 '16 at 9:13

I upgraded to version 4.3.0.37 because version 4.2.0.13 was not allowing me to login anymore with the error “Can’t connect”.

Unfortunately for me after hours of trying I could not get pulseaudio to work on my system, only ALSA is working so I downgraded back to 4.2.0.13

To solve the login error I spoofed the version number 4.2.0.13 to the latest 4.3.0.37 version and login was working again, problem solved.

So to solve your problem simply downgrade back to 4.2.0.13 and spoof to 4.3.0.37 version, exit Skype and run this command:

sudo sed -i "s/\x34\x2E\x32\x2E\x30\x2E\x31\x33/\x34\x2E\x33\x2E\x30\x2E\x33\x37/g" /usr/bin/skype

After you should be able to login as normal.

For those who tried all the above but are still struggling (like I was):

The problem might only be the server you use for your Ubuntu update (it was in my case). The server I was using did not had the right definition of libqtwebkit4:i386.

To solve that:

  • Open System Settings
  • Software & Updates
  • Ubuntu Software tab
  • Download from (Other... and select Best server)

Update your system with sudo apt-get update and then:

wget -O skype-install.deb http://www.skype.com/go/getskype-linux-deb
sudo dpkg -i skype-install.deb

Worked for me.

protected by Community Jan 1 '15 at 16:15

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.