0

I am trying to move a Ruby site to a new host that's running Ubuntu 14.04, but it needs Ruby 1.8.7. I can use rvm to install 1.8.7, but I'm unsure of how to get rails, gems, and passenger working for this version as well.

What do I need to run to set up rails, gems, and passenger for ruby 1.8.7 on my new Ubuntu machine?

-1

You should check gems versions that match the Ruby version.

Example:

https://rubygems.org/gems/passenger

That "Ruby Dependency >= 0" It means it will work on any version.

Another example:

Rake gem 10.2.1 depends of Ruby >= 1.9: https://rubygems.org/gems/rake/versions/10.2.1

But click on another version like this: https://rubygems.org/gems/rake/versions/10.2.2 and it says ">= 1.8.7" and it should work in your case.

So, you need to manually check for the right version of each gem.

  • This doesn't tell me what I asked. All you said was to check the version. I understand I don't have the right versions. What are the steps I need to perform to get the right versions for Ruby 1.8.7? – tubaguy50035 Aug 2 '14 at 6:50
  • I explained, you need to manually check at rubygems site the right versions. Like I did in the examples. – Jirico Aug 3 '14 at 3:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.