1

I have tried to install the fglrx proprietary drivers for my Radeon 9000 (RV250) graphics card. This didn't work so I tried to revert to the open-source version based on this page (purge fglrx) to uninstall fglrx and install the open-source version. It seems like I can't change the resolution from the very low 640 x 480 and the catalyst icons are still visible in the settings manager. I am running Xubuntu 14.04. There was no problem prior to the attempt at installing the proprietary version. The following command outputs may help:

lspci -nn | grep VGA
01:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] RV250 [Radeon 9000 Series] [1002:4966] (rev 01)

dmesg | egrep 'drm|radeon'
.....

no output is produced after the last command.

  • So would rolling back to the previous driver be ok? do you need this one for any specific reason? – Tim Jul 30 '14 at 15:00
  • If rolling back to the driver prior to the fglrx driver, yes. I don't need a proprietory driver at this stage. – Jacques MALAPRADE Jul 30 '14 at 15:11
1

The following seem to have done the trick. It seems like some packages were not included in the uninstall in the above link I provided.

sudo apt-get remove --purge fglrx fglrx-amdcccle fglrx-updates fglrx-amdcccle-updates

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.