10

I am trying to install Ubuntu for the first time.

Version = 11.04 Hardware = Acer Travelmate 4050

I can boot from USB or CD and it loads fine.

I have installed and reinstalled several times from both USB and CD and it completes correctly.

However, when I boot from the HDD I get the above error I don't see any errors like "kernel panic" mentioned elsewhere.

It happens whether I boot with AC adapter in or out and also with adapter in but battery out.

Not sure how to get further info to help with diagnosis Suggestions?

1
  • This also happens with other brands, eg Asus May 29 '19 at 6:21
7

appending acpi=off nomodeset xforcevesa worked for me (I have also an acer - TM4051 that halts on boot from HD)

People of non en-us keyboard-layout cultures need to know the en-us keyboard layout to do this.

The equal sign is top rightmost, the key right left before backspace:

en-us keyboard layout

2
  • 3
    Append acpi=off nomodeset xforcevesa where?
    – Cerin
    Jun 25 '16 at 20:48
  • I think in /etc/default/grub file on line GRUB_CMDLINE_LINUX Jun 6 '19 at 8:20
5

Here are a few things you can try - edit into your question with results if any either does or doesn't work.

  • Some more detail info about your laptop might give some advice on what to try next. Booting from Live CD/USB...

    ...Open a terminal and type

    lspci
    

    and

    lsusb
    

    and

    sudo lshw
    

    Copy and paste the results into your question.

  • Try turning off both power management and graphics driver loading during booting. To do this, edit /etc/default/grub, find the GRUB_CMDLINE_LINUX_DEFAULT= line, and add acpi=off nomodeset xforcevesa. That is, the new line will probably look like:

    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi=off nomodeset xforcevesa"
  • After that, run:

    sudo update-grub
    

    You can use this AU question to guide you through these two steps.

  • Then enter your BIOS settings - have a look at the following bios settings and try toggling the values one at a time and see if you can boot (assuming these options exist):

    a. Legacy USB Support
    b. Disk Management/SATA/IDE Compatability Mode

2
  • 1
    Hi fossfreedom Apologises for the long delay (just back from leave!) and thank you for the suggestions The boot line suggestions were the key ! Adding acpi=off nomodeset xforcevesa allowed it to boot from the HDD. I then got a message saying that there were updates (lots !) available, so I let them all run and when it rebooted it loaded just fine ! It even throws up a message telling me that the battery is stuffed (which it is!) so I guess that means power management is working too. So thanks again, this problem is FIXED!
    – Gordon
    Jul 25 '11 at 13:31
  • Thank you for your fix. It fixed my problem installing ubuntu server 16 on an old HP laptop
    – Pierre
    Nov 11 '17 at 19:55
3

In my case this happened because my headphone was connected to the laptop. Disconnecting it and rebooting helped solve the issue.

Thus try unplugging any connected devices like headphones, pen drives etc. and reboot.

2

I faced the same issue today. For the Travelmate 4050 a BIOS update from 1.6.0 to 1.7.0 resolved the issue as well, the setting acpi=off is not needed any more (this is very nice, because acpi=off prevents the laptop from shutting down properly).

1

Unplugging all peripherals solved my problem on a Dell Inspiron 7546 laptop after installing Ubuntu Budgie 19.

The original problem was that, after the install, the final reboot attempt hung with errors like, fixing recursive fault but reboot is needed and apparmor="STATUS" operation="profile_load" profile="unconfined".

As Abhishek Jebaraj recommended, the solution was that I unplugged everything (USB keyboard and mouse, HDMI cable, etc.) and held down the power button until the laptop shut down. Then I just pressed the power button and the laptop successfully booted into Ubuntu Budgie with no errors or problems.

Incidentally, although I unplugged my awesome Plugable USB 3.0 Gigabit Ethernet Adapter in order to get the laptop to boot, I simply plugged it back in after that first problematic reboot. After that I didn't have any problems with it or any other peripherals, even when rebooting again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.