2

I have just updated my laptop (toshiba qosmio F60), from ubuntu 12.04 to 14.04(.1) with a "clean" installation using the usb disk. The wifi didn't work properly on ubuntu 12.04 (that's why I updated), but on 14.04 it's even worst. On Windows 7 it works perfectly.

I can see the wireless networks, but I cannot connect to them. It tries to connect several times without success, and after such tries, the wifi disconnects after next reboot. This happens both at home and at work (so I assume routers aren't the problem, since on windows 7, and also my android phone, can connect to them properly).

I have a Realtek RTL8191SEvB card. This is the output of lshw -C network (sorry, translated from spanish):

*-network               
description: Wireless interface
product: RTL8191SEvB Wireless LAN Controller
manufacturer: Realtek Semiconductor Co., Ltd.
physical id: 0
bus information: pci@0000:03:00.0
logic name: wlan0
version: 10
series: b4:74:9f:49:fd:ba
width: 32 bits
clock: 33MHz
capacity: pm msi pciexpress bus_master cap_list ethernet physical wireless
configuration: broadcast=yes driver=rtl8192se driverversion=3.13.0-32-generic firmware=N/A latency=0 link=no multicast=yes wireless=IEEE 802.11bgn
resourcess: irq:17 ioport:3000(size=256) memoria:d3600000-d3603fff

I have searched this problem for several hours. All the solutions I found correspond to previous kernel versions (in which you have to re-compile the Realtek driver). However, since kernel 3.8 (I am using 3.13), the Realtek driver is already included. I have also tried the ndiswrapper with the windows xp driver, but the problem goes worst and the wifi option on the network-manager doesn't even appear. The only workaround solution I found is to change to Debian, but I would like to keep using Ubuntu. Any idea of what is going on?

Thank you in advance for your responses.

P.S.: Find attached the lsmod output:

Module                  Size  Used by
rc_dib0700_rc5         12508  0 
tuner_xc2028           31249  1 
snd_hda_codec_hdmi     46254  4 
snd_hda_codec_realtek    61438  1 
arc4                   12608  2 
btusb                  32412  0 
snd_hda_intel          52355  5 
rfcomm                 69160  8 
bnep                   19624  2 
snd_hda_codec         192906  3 snd_hda_codec_realtek,snd_hda_codec_hdmi,snd_hda_intel
bluetooth             391196  22 bnep,btusb,rfcomm
dvb_usb_dib0700       144289  0 
dib8000                57402  1 dvb_usb_dib0700
dib7000m               22858  1 dvb_usb_dib0700
dib0090                38185  1 dvb_usb_dib0700
dib0070                18232  1 dvb_usb_dib0700
dib7000p               38420  2 dvb_usb_dib0700
snd_hwdep              13602  1 snd_hda_codec
snd_pcm               102099  3 snd_hda_codec_hdmi,snd_hda_codec,snd_hda_intel
uvcvideo               80885  0 
snd_page_alloc         18710  2 snd_pcm,snd_hda_intel
dib3000mc              23239  1 dvb_usb_dib0700
snd_seq_midi           13324  0 
snd_seq_midi_event     14899  1 snd_seq_midi
snd_rawmidi            30144  1 snd_seq_midi
nvidia              10675249  43 
snd_seq                61560  2 snd_seq_midi_event,snd_seq_midi
rtl8192se              63196  0 
videobuf2_vmalloc      13216  1 uvcvideo
videobuf2_memops       13362  1 videobuf2_vmalloc
videobuf2_core         40664  1 uvcvideo
dibx000_common         18752  5 dib8000,dvb_usb_dib0700,dib3000mc,dib7000m,dib7000p
dvb_usb                24215  1 dvb_usb_dib0700
coretemp               13435  0 
videodev              134688  2 uvcvideo,videobuf2_core
dvb_core              121659  3 dib8000,dvb_usb,dib7000p
snd_seq_device         14497  3 snd_seq,snd_rawmidi,snd_seq_midi
rc_core                28124  4 dvb_usb,dvb_usb_dib0700,rc_dib0700_rc5
rtl_pci                26690  1 rtl8192se
snd_timer              29482  2 snd_pcm,snd_seq
rtlwifi                63475  2 rtl_pci,rtl8192se
kvm_intel             143060  0 
snd                    69238  21 snd_hda_codec_realtek,snd_hwdep,snd_timer,snd_hda_codec_hdmi,snd_pcm,snd_seq,snd_rawmidi,snd_hda_codec,snd_hda_intel,snd_seq_device,snd_seq_midi
kvm                   451511  1 kvm_intel
mac80211              630653  3 rtl_pci,rtlwifi,rtl8192se
soundcore              12680  1 snd
cfg80211              484040  2 mac80211,rtlwifi
mei_me                 18627  0 
joydev                 17381  0 
serio_raw              13462  0 
lpc_ich                21080  0 
parport_pc             32701  0 
i7core_edac            24122  0 
toshiba_acpi           22901  0 
drm                   303102  2 nvidia
edac_core              62291  1 i7core_edac
mei                    82276  1 mei_me
sparse_keymap          13948  1 toshiba_acpi
ppdev                  17671  0 
mac_hid                13205  0 
lp                     17759  0 
wmi                    19177  1 toshiba_acpi
toshiba_bluetooth      12852  0 
video                  19476  0 
parport                42348  3 lp,ppdev,parport_pc
hid_generic            12548  0 
usbhid                 52570  0 
hid                   106148  2 hid_generic,usbhid
psmouse               106678  0 
ahci                   25819  2 
r8169                  67581  0 
libahci                32560  1 ahci
sdhci_pci              23172  0 
mii                    13934  1 r8169
sdhci                  43015  1 sdhci_pci

closed as off-topic by bain, Warren Hill, user68186, LnxSlck, Eric Carvalho Aug 2 '14 at 13:44

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Bug reports and problems specific to development version of Ubuntu should be reported on Launchpad so that developers can see, track and fix these issues." – bain, Warren Hill, user68186, LnxSlck, Eric Carvalho
If this question can be reworded to fit the rules in the help center, please edit the question.

  • Report a bug at Launchpad. Do you see any errors in /var/log/syslog or /var/log/kern.log? You could try updating to a new mainline PPA kernel. – bain Jul 30 '14 at 9:16
  • Sounds like a bug so voting to close this question. Follow this wireless troubleshooting procedure to ask a question on Launchpad. If it is a bug it will be converted to one, if not you should get an answer. – Warren Hill Jul 30 '14 at 11:01
  • Welcome to Ask Ubuntu. Please do not put (SOLVED) in the title. You can put a green check mark next to the answer to indicate that it is correct. This can be your own answer. – user68186 Jul 30 '14 at 18:55
  • Thanks, and sorry for my "forum-ize" mind! I'll accept my own answer in 20 hours to close the question. – Miguel Jul 31 '14 at 11:28
2

Thanks for your comments!

Fortunately, I found a solution! I upgraded my kernel version to 3.15.7 (the last stable version to date). Now the wifi works like a charm! And much better than in 12.04. Thus, it seems that the wifi driver for my card (Realtek 8191SE) in kernel 3.13 was bad, or there were interferences.

Anyway, I'll update the question to solved, just in case somebody else has the same problem.

About how I updated the kernel version, I have just followed this link.

  • It would also be very useful if you reported this bug on Launchpad along with the fact that 3.15.7 works. Just do ubuntu-bug linux-image-3.13.0-32-generic – bain Jul 30 '14 at 21:04

Not the answer you're looking for? Browse other questions tagged or ask your own question.