I am trying to add nodes in MAAS cluster. I setup MAAS Server in VM using Ubuntu 14.04 LTS. I completed the post-install tasks like installing MAAS, configure network, DHCP-DNS, creating logins, importing boot images as explained here:

In the node's BIOS, I did change the boot order so that it boots from the LAN and node successfully booting up from PXE boot from the MAAS cluster controller through atuo detect node function and MAAS DHCP server giving IP address from its DHCP range to node (In this process first time I switched on the node from its power button not from MAAS)

After completing above process the machine is now showing "declared" in MAAS and node automatically power down.

Wake-on-lan details are already configured on node and just to make sure if everything working fine I tested Wake-on-lan function from my mobile phone app and its working without any problem.

Now I checked "Commission" from menu but commissioning not pulling additional information from node (node is off because MAAS not sending magic packets to node's wake-on-lan) but if I switch on my node by my self through my mobile app after showing lots of lines once again node power down then node showing me 'Ready' status in MAAS but when I check node CPU and RAM details, it's showing me 0MB 0CPU.

After completing above task MAAS showing me node status is ready and then I tried to start node from MAAS it says "The action "Commission selected nodes" could not be performed on 1 node because its state does not allow that action."

Main Issue: Node wake-on-lan 100% working from my mobile app but MAAS not sending magic packets to node from step one. There is no firewall between MAAS, Node and Mobile.

Important: I am using using MAAS DHCP for my entire network so I can browse internet from my cell phone with MAAS DNS.

  • 1
    After googling I found that almost 99% MAAS users has some issue and there is no clear Wiki documents or instructions are available from Ubuntu and other remaining 1% doesn't have clear idea so can't help community. I am considering MAAS is not mature enough or not good software for production environment. Ubuntu needs more work to do on this project.
    – jugnu
    Jul 31, 2014 at 7:44
  • I have been messing around with this issue for a couple of days now. I have the same symptom, maas doesn't send the wake on lan out the correct port. If I do it manually with the wakeonlan program (using the interface argument) then my device wakes up.
    – Greg
    Aug 13, 2015 at 12:18

3 Answers 3


I just discovered that MAAS uses either Etherwake or Wakeonlan to boot the nodes, if using power type wake-on-lan.

Those are not installed by default, and are not dependencies of MAAS.

Just install Etherwake or Wakeonlan from the standard Ubuntu repo

apt-get install etherwake


apt-get install wakeonlan

Then, when you manually add a node using MAAS, use wake-on-lan power type with your MAC address, and as soon as you save the node, the party begins!

I found the information in the following file, take a look:

  • Since MAAS version 2.0 the place has been changed. Does anybody know where to look?
    – user366546
    May 8, 2016 at 13:40

You may not need both wakeonlan and etherwake. The template for wakeonlan in /etc/maas/templates/power/ether_wake.template checks for wakeonlan first and checks etherwake if wakeonlan is not installed.

I found that my servers would wake up if I used etherwake, but not with wakeonlan. etherwake defaults to using eth0. My maas server needed to use em1 instead so I added the "-i em1" option to the etherwake command in the template, but maas still fails to wake up my servers.

Found more. etherwake uses udp which requires it to run as root, not the maas user. The fix is to place the following line in a file in /etc/sudoers.d

maas ALL= NOPASSWD: /usr/sbin/etherwake

and adjust the following line in /etc/maas/templates/power/ether_wake.template from: /usr/sbin/etherwake $mac_address to: sudo /usr/sbin/etherwake $mac_address

or if you need to use something beside eth0:

sudo /usr/sbin/etherwake -i ethint $mac_address

  • The first part is an answer to the original question. The last line is an answer to one more area that could cause it to fail (as it did in my case). I have also submitted a bug report with this solution in it on bugs.launchpad.net Nov 26, 2014 at 19:40
  • what's the launchpad bug? Apr 16, 2015 at 17:42
  • bugs.launchpad.net is where you file bugs for to be reviewed and corrected by the developers. If you find things that don't work correctly, this is where you let the developers know about it. May 18, 2015 at 14:42
  • yes.. i know, I'm merely asking for the relevant bug number you filed on launchpad May 18, 2015 at 15:32
  • It was bug #1396740 May 18, 2015 at 21:21

This didnt seem to work in version 2.2.2 of MAAS with my system, so I wrote a fix, based on a fix for a previous version


Follow the instructions in the README.md to install

Basically, only etherwake worked on my system (not wakeonlan) so I rewrote the plugin to use etherwake.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.