I'm new to Linux.
My current goal is to build my own LiveCD of Ubuntu. Small size, tiny gui, controlled by vnc and/or ssh.

My workspace is a 12.04 full installation in Virtual Box.

As the "base" I try to use a copy of the "Ubuntu Mini Remix" (tried 13.10 and 12.04).
For remastering I tried the ubuntu-builder, the uck and Customizer.
(uck and Customizer (could) work great).

My problems is, no matter what tool I use, it ends up failing every time with the same error. A screen filled with a lot of Authentication Failure messages. Even when I only feed the iso to one of the programs and immediately recreate the iso.

I found out, that it maybe it has something to do with the dynamically created default user called ubuntu, which the system uses as the user used to boot.
In the chroot environment I could not find the user in the passwd. I guess the generation process is defined in the casper.conf.

I tried modifying the casper.conf, but to no luck.

Why can't I just tell the system what user to use, when it boots?
Or why does the generating process of the default user called ubuntu break, if I touch the iso? (maybe it does work, but the authentication on boot dislikes the generated user.)

  • I think the issue has to do with openssh-server. Did you install that on your LiveCD while you were customizing it? – SW_user2953243 Oct 9 '14 at 17:04

What worked for me was installing user-setup While recording my screen, I booted the LiveCD (in a VM) in "text" mode. While reviewing the text I noticed there was an error that it could not create the Live Session user and that chroot couldn't execute /usr/lib/user-setup/user-setup-apply because the file didn't exist.

So I customized my already-customized ISO, installing user-setup via apt-get (apt-get install user-setup) and I could finally "Try" my LiveCD without installing.

I'm not sure how the user-setup package got removed during my customization process.

Without your LiveCD, it's difficult to diagnose what exactly caused your specific issue. But maybe this answer will help you fix your LiveCD or others encountering a similar issue who - like me - can't find any solutions online.

On another note, my previous post received a down vote and was converted to comment- I'm not allowed to comment because I don't have the reputation (that down vote doesn't help me get there).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.