1

I am using Ubuntu 14.04 on a Dell Inspiron 11. It uses Intel's Integrated graphics cards. The problem I'm having is when ever I bring something up on the screen that is dark (such as a terminal screen) my computer dims, and its a real pain as it makes it hard to view some items. From what I've found it appears to be related to some type of dynamic contrast, but for the life of me, I can't figure out how to turn it off.

1

After a little bit of research, I found a way to disable this action.

I have an HP 3105m on xubuntu, with the fglrx driver.

In my situation, this only occurs when I go from being plugged in, to unplugging my power. Since it was triggered by a power change, I immediately thought acpi was the cause of action.

Now, I don't know how different it will be with other drivers, but I might as well put what I did out there.

What triggers this is an event file in /etc/acpi/events/, in my case there was a file named fglrx-ac-aticonfig pointing to a script in /etc/acpi/ named fglrx-powermode.sh

EDIT: You could aso just comment out everything in /etc/acpi/events/fglrx-ac-aticonfig, That may work better.

In this file I commented out the lines executing /usr/bin/aticonfig with su

In my case the line looks like this:

su $user -c "/usr/bin/aticonfig --set-powerstate=$powermode --effective=now" &>/dev/null

All I did was comment that out, and the problem disapeared.

I'm not sure what it looks like with intel drivers, but it may still apply on your end.

EDIT:

Turns out that doesn't work.

If you're using fglrx, open amdcccle, go under "PowerPlay" and uncheck "Enable VariBright"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.